Bug 1223609 - JDK8 JasperException: Unable to compile class for JSP. type java.util.Map$Entry cannot be resolved
Summary: JDK8 JasperException: Unable to compile class for JSP. type java.util.Map$Ent...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tomcat6
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Coty Sutherland
QA Contact: tomcat-qe
URL:
Whiteboard:
: 1338903 (view as bug list)
Depends On: 1104217 1336481
Blocks: 1172231 1275725
TreeView+ depends on / blocked
 
Reported: 2015-05-21 02:26 UTC by Hisanobu Okuda
Modified: 2019-11-14 06:43 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1104217
Environment:
Last Closed: 2017-03-21 12:09:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
sample.war (2.38 KB, application/zip)
2015-05-21 02:27 UTC, Hisanobu Okuda
no flags Details
Fixed sample.war (3.41 KB, application/zip)
2015-11-18 16:08 UTC, Robert Bost
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2294701 None None None 2016-05-02 17:35:26 UTC

Comment 1 Hisanobu Okuda 2015-05-21 02:27:43 UTC
Created attachment 1027944 [details]
sample.war

Comment 2 Hisanobu Okuda 2015-05-21 02:28:55 UTC
steps to reproduce:-

1. run tomcat6 on openjdk8/rhel6
2. deploy the attached sample.war
3. access http://localhost:8080/sample/

Comment 6 Robert Bost 2015-11-18 16:08:27 UTC
Created attachment 1096145 [details]
Fixed sample.war

Comment 8 Jean-frederic Clere 2015-11-23 10:39:35 UTC
I think you need to upgrade ecj to eclipse-ecj-4.4.jar or higher to fix the problem.

Comment 11 Coty Sutherland 2015-12-01 12:50:48 UTC
To resolve this bug would require an update of the ECJ library to at least version 4.4. Given that we don't have any users experiencing this issue at the moment and that the issue can be worked around by moving the bad code (which uses Maps) from the JSP into a Servlet, or helper class, I am closing this out.

Comment 12 Coty Sutherland 2015-12-01 12:52:21 UTC
Also note that another alternative would be to use Java 7.

Comment 14 Coty Sutherland 2016-05-20 14:09:02 UTC
*** Bug 1337940 has been marked as a duplicate of this bug. ***

Comment 19 Elliott Baron 2016-08-16 21:53:38 UTC
*** Bug 1338903 has been marked as a duplicate of this bug. ***

Comment 20 Coty Sutherland 2016-08-18 17:57:02 UTC
This bug is really a no-op for tomcat; once the dependent bug (https://bugzilla.redhat.com/show_bug.cgi?id=1336481) is fixed, then we can close this one as closed/currentrelease.

Comment 21 Coty Sutherland 2017-03-21 12:09:40 UTC
The ECJ update (bug 1336481) has been released.


Note You need to log in before you can comment on or make changes to this bug.