Bug 1223658 - Quota: Account in-progress/parallel writes
Summary: Quota: Account in-progress/parallel writes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Raghavendra G
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1354259
TreeView+ depends on / blocked
 
Reported: 2015-05-21 07:28 UTC by Vijaikumar Mallikarjuna
Modified: 2018-08-29 03:35 UTC (History)
2 users (show)

Fixed In Version: glusterfs-4.1.3 (or later)
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1354259 (view as bug list)
Environment:
Last Closed: 2018-08-29 03:35:25 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijaikumar Mallikarjuna 2015-05-21 07:28:36 UTC
Currently in-progress writes and parallel writes are not accounted, so there is a possibility of exceeding quota by few % even when hard-limit and soft-limit is set to 0.

Comment 1 Vijay Bellur 2016-04-15 17:53:54 UTC
REVIEW: http://review.gluster.org/14006 (quota: consider inprogress writes during enforcement) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Vijay Bellur 2016-04-15 18:44:14 UTC
REVIEW: http://review.gluster.org/14006 (quota: consider inprogress writes during enforcement) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Vijay Bellur 2016-04-16 05:10:45 UTC
REVIEW: http://review.gluster.org/14006 (quota: consider inprogress writes during enforcement) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Vijay Bellur 2016-04-25 10:16:34 UTC
REVIEW: http://review.gluster.org/14006 (quota: consider inprogress writes during enforcement) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 7 Worker Ant 2016-09-30 06:14:18 UTC
REVIEW: http://review.gluster.org/14006 (quota: consider inprogress writes during enforcement) posted (#5) for review on master by Anonymous Coward

Comment 8 Worker Ant 2016-09-30 06:14:21 UTC
REVIEW: http://review.gluster.org/15598 (Bug-1223658 Quota tracking for parallel writes) posted (#1) for review on master by Anonymous Coward

Comment 9 Amar Tumballi 2018-08-29 03:35:25 UTC
This update is done in bulk based on the state of the patch and the time since last activity. If the issue is still seen, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.