Bug 122366 - kernel utils STILL needs to be split up!
kernel utils STILL needs to be split up!
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-utils (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 100489 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-03 15:16 EDT by Dan Hollis
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 19:16:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Hollis 2004-05-03 15:16:35 EDT
Description of problem:
kernel-utils is a conglomerate of 3 completely separate and unrelated
utilities. this package really should be split up, for the reasons
noted in bug #100489

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.download smartctl from sourceforge.
2.build rpm from included specfile.
3.try to install the rpm.
  
Actual results:
get package conflicts with kernel-utils for no good reason.

Expected results:
smartctl shouldnt be bundled in with unrelated programs in an rpm. (i
dont think any rpm should ever do this, really)

Additional info:
This bug has been open and pending since 2003-07-22. It should be
simple to resolve (simply break the package up). Is there a good
reason why this hasn't been done?
Comment 1 Dan Hollis 2004-05-03 15:18:40 EDT
*** Bug 100489 has been marked as a duplicate of this bug. ***
Comment 2 Marcin Garski 2004-11-30 06:58:49 EST
I totaly agree with Dan!

Another similiar request (almost the same, but for excluding only
smartmontools, so I dunno to close it as duplicate) bug #108569
Comment 3 Dan Hollis 2004-12-02 14:26:54 EST
Ok, kernel-utils is getting silly now.

We have cpuspeed, dmidecode, irqbalance, microcode_ctl, hw_random,
readahead, and smart-utils all in the same package, despite the fact
these are all completely separate and completely unrelated utilities.

this bug has been open since 2003-07-22.

please stop the madness!
Comment 4 Dave Jones 2005-01-10 19:16:25 EST
done.

Note You need to log in before you can comment on or make changes to this bug.