Bug 122373 - genhdlist needs to require pkgorder information
Summary: genhdlist needs to require pkgorder information
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-03 20:06 UTC by Joshua Jensen
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 22:17:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Jensen 2004-05-03 20:06:04 UTC
Description of problem:

At least with AMD64, running genhdlist will create broken hdlist
files, unless the "optional" --fileorder file is provided.

I would say this is a bug.  pkgorder isn't really option for genhdlist
 to work correctly

Version-Release number of selected component (if applicable):

RHEL3 AMD64

Comment 1 Jeremy Katz 2004-05-06 22:17:00 UTC
It doesn't always require it.  It depends on the package set and the
architecture you're on in a lot of ways (ie, a basic i386 only run
doesn't necessarily need it).

Comment 2 Trevin Beattie 2004-07-27 19:48:14 UTC
I've seen this break on an i686 system as well.  genhdlist apparently
generates a hdlist with packages listed in alphabetical order, which
is how anaconda tries to install them.  This fails, because
dependencies don't get installed before the packages which depend on
them, resulting in a lot of errors about missing libraries, users,
files, etc.  One of the most important packages, grub, fails to
install the boot image in /boot because of these errors, so the server
is unbootable.


Comment 3 Joshua Jensen 2004-07-27 20:41:22 UTC
I wonder, is there a reason that you wouldn't *want* to run pkgorder ?
Why not make it a requirment?


Note You need to log in before you can comment on or make changes to this bug.