Bug 122379 - "No such file or directory" while installing x86_64 gnome-applets
Summary: "No such file or directory" while installing x86_64 gnome-applets
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
: 125649 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-03 20:50 UTC by Michal Jaegermann
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: gnome-applets-2.6.2.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-27 07:40:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2004-05-03 20:50:28 UTC
Description of problem:

'gnome-applets' installation on x86_64 results in the following
complaints:

I/O warning : failed to load external entity
"/etc/gconf/schemas/battstat.schemas"
Failed to open `/etc/gconf/schemas/battstat.schemas': No such file or
directory

and indeed there is no such file or directory.

What about changing a code on a %post script to something like that:

for S in $SCHEMAS; do
  S=/etc/gconf/schemas/$S
  [ -r $S ] || continue
  gconftool-2 --makefile-install-rule $S > /dev/null
done

Version-Release number of selected component (if applicable):
gnome-applets-2.6.0-4

How reproducible:
always

Comment 1 Mark McLoughlin 2004-07-19 14:45:54 UTC
*** Bug 125649 has been marked as a duplicate of this bug. ***

Comment 2 Mark McLoughlin 2004-07-22 16:24:15 UTC
Just pushed a testing update which should fix this:

http://www.redhat.com/archives/fedora-test-list/2004-July/msg00494.html

Appreciate if someone could try it out and confirm.

Comment 3 Michal Jaegermann 2004-07-22 17:52:52 UTC
The test update works; but I wonder if instead of a static list
of schemas in a %post section of gnome-applet.spec, which always
poses a risc of getting out of sync, there is a way to create
that list automatically.  From a content of
$RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/ maybe?

I never tried if a "late %define" in a spec file would be feasible
but that would look like one possibility of passing that information
to a %post section.

Comment 4 Mark McLoughlin 2004-07-23 09:00:57 UTC
I guess we explicitly list the schema files we're installing because
we want to know when new schema files have been added in a new
upstream version.

This is an unusual case - schemas not being installed on certain
architectures.

Thanks for testing the update :-)

Comment 5 Mark McLoughlin 2004-07-27 07:40:26 UTC
Okay, gnome-applets-2.6.2.1-1 has been pushed to FC2 updates


Note You need to log in before you can comment on or make changes to this bug.