Bug 122383 - mixer_applet2 forgets mixer settings with a panel restart.
mixer_applet2 forgets mixer settings with a panel restart.
Status: CLOSED DUPLICATE of bug 120354
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-03 17:38 EDT by David L Norris
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David L Norris 2004-05-03 17:38:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040422 Epiphany/1.1.12

Description of problem:
mixer_applet2 does not save settings between panel restarts.  The
master volume mutes upon login.  Mixer channel preferences are forgotten.

Version-Release number of selected component (if applicable):
gnome-applets-2.6.0-4

How reproducible:
Always

Steps to Reproduce:
1. Add a "Volume Control" applet to a panel.
2. Master volume is selected by default.
3. Right-click and choose preferences.
4. Select any channel except the master volume (e.g. rear volume).
5. Logout/Login or restart panel.


Actual Results:  Panel starts up with mixer set to the master volume.
 A split second after the mixer appears the master volume mutes.

Expected Results:  mixer_applet2 should not change the volume by
itself.  mixer_applet2 should remember the proper channel assignments.

Additional info:

This is probably related to ALSA.

This upstream bug appears to be similar and includes a patch but it is
still marked as new:
  http://bugzilla.gnome.org/show_bug.cgi?id=139374
Comment 1 Nils Philippsen 2004-05-06 07:53:27 EDT

*** This bug has been marked as a duplicate of 120354 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.