Bug 1223845 - register-ds-admin.pl script prints clear text password in the terminal
Summary: register-ds-admin.pl script prints clear text password in the terminal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: Admin
Version: 10.0
Hardware: All
OS: Linux
high
medium
Target Milestone: DS10.0
: ---
Assignee: Rich Megginson
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-21 14:25 UTC by Sankar Ramalingam
Modified: 2015-06-12 01:04 UTC (History)
1 user (show)

Fixed In Version: 389-admin-1.1.41-1.el7dsrv
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-12 01:04:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1094 normal SHIPPED_LIVE Red Hat Directory Server bug fix and enhancement update 2015-06-12 05:02:14 UTC

Description Sankar Ramalingam 2015-05-21 14:25:49 UTC
Description of problem: When trying to register a new instance remotely, I observed that it prints the password on the terminal.


Version-Release number of selected component (if applicable): 389-admin-1.1.40-1.el7dsrv.x86_64


How reproducible: Consistently


Steps to Reproduce:
1. Install directory server 10.0 packages on RHEL7.1 machine.
2. Run register-ds-admin.pl script to register an existing instance to a remote admin server.
3. Choose "y" when it asks whether you want to register remote server with the local configuration server.

Enter Remote hostname: cloud-qe-22.idmqe.lab.eng.bos.redhat.com
Enter Remote port: 1189
Enter Remote bind DN: "cn=Directory Manager"
Enter Remote bind password: Secret123

Actual results: Clear text password on the command line.


Expected results: Password shouldn't be visible.


Additional info:

Comment 1 Noriko Hosoi 2015-05-27 06:04:20 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/48186

Comment 3 Sankar Ramalingam 2015-06-01 17:59:35 UTC
Enter Remote port: 1222
Enter Remote bind DN: cn=Directory Manager
Enter Remote bind password:
If using SSL, enter certificate db directory: 


Password not printed in the command line. Hence, marking the bug as Verified.

Build tested:
389-admin-1.1.41-1

Comment 5 errata-xmlrpc 2015-06-12 01:04:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1094


Note You need to log in before you can comment on or make changes to this bug.