Bug 1223932 - UnicodeEncodeError: 'ascii' codec can't encode character u'\xe1' in position 19: ordinal not in range(128)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe1' in position ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
armv7hl Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
: 1224949 1225397 1225681 1226464 1226757 1226760 1228904 1229054 1229346 1230361 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-21 14:03 EDT by Juan Orti
Modified: 2015-07-24 08:38 EDT (History)
17 users (show)

See Also:
Fixed In Version: dnf-1.0.1-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-20 20:16:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Orti 2015-05-21 14:03:18 EDT
Description of problem:
I hit this error, but with LANG=C it works.

# echo $LANG
es_ES.utf8


# dnf groupinstall "Basic Desktop"
Last metadata expiration check performed 2:17:38 ago on Thu May 21 17:35:55 2015.
Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 185, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 134, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1077, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/group.py", line 385, in run
    return self.base.env_group_install(patterns, types)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 1253, in env_group_install
    res.groups, types)
  File "/usr/lib/python2.7/site-packages/dnf/comps.py", line 88, in install_or_skip
    logger.warning("%s, %s", str(e)[:-1], _("skipping."))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe1' in position 19: ordinal not in range(128)

# LANG=C dnf groupinstall "Basic Desktop"
Last metadata expiration check performed 2:18:05 ago on Thu May 21 17:35:55 2015.
Group 'Basic Desktop' is already installed, skipping.
Error: package PackageKit-gstreamer-plugin-1.0.6-3.fc22.armv7hl requires PackageKit-glib(armv7hl-32) = 1.0.6-3.fc22, but none of the providers can be installed.
package lightdm-1.10.4-1.fc22.armv7hl requires dbus-x11, but none of the providers can be installed.
package initial-setup-gui-0.3.31-1.fc22.armv7hl requires anaconda-gui >= 21.46, but none of the providers can be installed.
package plymouth-system-theme-0.8.9-7.2013.08.14.fc22.armv7hl requires plymouth(system-theme) = 0.8.9-7.2013.08.14.fc22, but none of the providers can be installed.
package abrt-cli-2.5.1-2.fc22.armv7hl requires abrt-addon-python, but none of the providers can be installed


Version-Release number of selected component (if applicable):
python-dnf-plugins-extras-common-0.0.7-1.fc22.noarch
dnf-conf-1.0.0-1.fc22.noarch
dnf-yum-1.0.0-1.fc22.noarch
python-dnf-plugins-core-0.1.8-1.fc22.noarch
python-dnf-1.0.0-1.fc22.noarch
python-dnf-plugins-extras-migrate-0.0.7-1.fc22.noarch
dnf-plugins-core-0.1.8-1.fc22.noarch
dnf-1.0.0-1.fc22.noarch
yum-utils-1.1.31-505.fc22.noarch
yum-metadata-parser-1.1.4-14.fc22.armv7hl
yum-3.4.3-505.fc22.noarch
Comment 1 Parag Nemade 2015-05-28 01:53:35 EDT
I think this can be fixed by simple commit -> https://github.com/rpm-software-management/dnf/pull/280
Comment 2 Honza Silhan 2015-05-28 07:18:41 EDT
I have modified Parag's commit to work in Python3 too. Fixed in the upstream.
Comment 3 Honza Silhan 2015-06-01 06:19:06 EDT
*** Bug 1225397 has been marked as a duplicate of this bug. ***
Comment 4 Honza Silhan 2015-06-01 06:57:07 EDT
*** Bug 1226760 has been marked as a duplicate of this bug. ***
Comment 5 Radek Holy 2015-06-01 07:32:41 EDT
*** Bug 1226757 has been marked as a duplicate of this bug. ***
Comment 6 Parag Nemade 2015-06-08 00:32:12 EDT
*** Bug 1225681 has been marked as a duplicate of this bug. ***
Comment 7 Parag Nemade 2015-06-08 00:33:04 EDT
*** Bug 1226464 has been marked as a duplicate of this bug. ***
Comment 8 Parag Nemade 2015-06-08 00:33:09 EDT
*** Bug 1229054 has been marked as a duplicate of this bug. ***
Comment 9 Parag Nemade 2015-06-09 02:04:44 EDT
*** Bug 1229346 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2015-06-12 05:05:43 EDT
dnf-1.0.1-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-1.0.1-2.fc22
Comment 11 Fedora Update System 2015-06-14 13:33:38 EDT
Package dnf-1.0.1-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-1.0.1-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10004/dnf-1.0.1-2.fc22
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2015-06-20 20:16:24 EDT
dnf-1.0.1-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Honza Silhan 2015-07-22 09:56:20 EDT
*** Bug 1224949 has been marked as a duplicate of this bug. ***
Comment 14 Honza Silhan 2015-07-24 07:46:53 EDT
*** Bug 1228904 has been marked as a duplicate of this bug. ***
Comment 15 Honza Silhan 2015-07-24 08:38:29 EDT
*** Bug 1230361 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.