Bug 1224102 - [Backup]: Behaviour of backup api in the event of snap restore - unknown
Summary: [Backup]: Behaviour of backup api in the event of snap restore - unknown
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfind
Version: rhgs-3.1
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Bug Updates Notification Mailing List
QA Contact: Sweta Anandpara
URL:
Whiteboard:
Depends On: 1208404
Blocks: qe_tracker_everglades 1236025
TreeView+ depends on / blocked
 
Reported: 2015-05-22 08:32 UTC by Sweta Anandpara
Modified: 2018-04-02 13:15 UTC (History)
5 users (show)

Fixed In Version: RHGS 3.3.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1208404
Environment:
Last Closed: 2018-04-02 13:15:27 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sweta Anandpara 2015-05-22 08:32:13 UTC
+++ This bug was initially created as a clone of Bug #1208404 +++

Description of problem:

This is to ascertain what should be the right way of going about, when a user has backup tool running along with snapshots. 

Say a user has snapshots getting created at time stamps t1, t2, t3 .. 
At timestamp t4, a backup is taken using glusterfind api. This results in all the changes to get synced until t4. The status file $SESSION_DIR/status is updated with t4. IF the user at this point has a requirement to go back in time, he/she restores file(s) at timestamp t2. Now the changed file(s) would have the timestamp t2, which will NOT get recorded as 'changed files' in the next run of glusterfind pre command (as t2 < t4).

Possible ways to resolve:

1) We could ensure that 'snapshot restore' restores/updates the status file present in $SESSION_DIR, with the timestamp of the restored snapshot (in the above e.g., t2)

2) We could have clear warnings displayed to let the user know that the backup destination is not going to stay up-to-date, when he/she tries to run snapshot restore, unless a --full backup is done

3) We could update our documentation stating that caution would have to be exercised in case a user is using both backup as well as snap restore.


Version-Release number of selected component (if applicable):
Gluster 3.7 upstream nightly glusterfs-3.7dev-0.852.git3feaf16.el6.x86_64

--- Additional comment from Aravinda VK on 2015-05-09 10:33:30 EDT ---

This is not a bug, but needs documentation update.

1. following a snap restore, take a full backup to ensure the backup catalog/db stays in step the the volume state
2. expire backup copies taken between the original date of the snap and the restore date

Moving this Bug to MODIFIED state.

Comment 7 Amar Tumballi 2018-04-02 13:15:27 UTC
The source bug is closed in 3.7.x version of glusterfs which means, is fixed from RHGS-3.3.0 + versions.


Note You need to log in before you can comment on or make changes to this bug.