Bug 122413 - Problem creating volumes in extended partition
Problem creating volumes in extended partition
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 01:01 EDT by Ken Roser
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 18:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Roser 2004-05-04 01:01:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20031208

Description of problem:
Assume that fedora is being installed in an extended partition.  All 3
volumes, /, boot and swap will be added in this extended partition. 
Also assume there's already one volume existing already in this
extended partition and it's at the high end of the partition.

When fedora creates the necessary 3 volumes, it modifies the chain of
extended boot records for the extended partition.  Instead of placing
the new volumes at the beginning of the chain (since they're the first
in the partition), they get linked at the end of the chain.  Although
this produces no observable problems with Fedora, if a partition
editor such as BootIt NG is used to delete this Fedora partitions in
the future, the chain will be interpreted incorrectly due to the
misordering of the volumes.  The symptom with BootIt NG will be that
after deleting the linux volumes, no free space will be shown in the
extended partition.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Follow the scenario in the description
2.
3.
    

Actual Results:  EBR chain is in wrong order

Expected Results:  New linux volumes should be first in the EBR chain.

Additional info:
Comment 1 Jeremy Katz 2004-05-06 18:24:46 EDT
This is perfectly legal according to how MSDOS partition tables are
specified.  It's a bug in the third-party program if it can't handle
partition numbers being out of sequence.

Note You need to log in before you can comment on or make changes to this bug.