Bug 1224187 - binutils FTBFS during stage1 bootstrap - logical not is only applied to the left hand side of comparison
binutils FTBFS during stage1 bootstrap - logical not is only applied to the l...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nick Clifton
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks: fedora-bootstrap
  Show dependency treegraph
 
Reported: 2015-05-22 06:11 EDT by Jaromír Cápík
Modified: 2016-01-31 21:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-11 11:17:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
binutils.log (242.62 KB, text/plain)
2015-05-22 06:11 EDT, Jaromír Cápík
no flags Details
binutils-2.24-i386-logical-not.patch (573 bytes, text/plain)
2015-05-22 06:13 EDT, Jaromír Cápík
no flags Details

  None (edit)
Description Jaromír Cápík 2015-05-22 06:11:45 EDT
Created attachment 1028679 [details]
binutils.log

Description of problem:
During stage1 bootstrap we experience FTBFS caused by unsupported evaluation.

----
gcc -DHAVE_CONFIG_H -I. -I/home/fedora-bootstrap/rpmbuild/BUILD/binutils-2.24/gas  -I. -I/home/fedora-bootstrap/rpmbuild/BUILD/binutils-2.24/gas -I../bfd -I/home/fedora-bootstrap/rpmbuild/BUILD/binutils-2.24/gas/config -I/home/fedora-bootstrap/rpmbuild/BUILD/binutils-2.24/gas/../include -I/home/fedora-bootstrap/rpmbuild/BUILD/binutils-2.24/gas/.. -I/home/fedora-bootstrap/rpmbuild/BUILD/binutils-2.24/gas/../bfd -DLOCALEDIR="\"/home/fedora-bootstrap/install/share/locale\""  -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Werror -g -O2 -MT atof-ieee.o -MD -MP -MF .deps/atof-ieee.Tpo -c -o atof-ieee.o `test -f 'config/atof-ieee.c' || echo '/home/fedora-bootstrap/rpmbuild/BUILD/binutils-2.24/gas/'`config/atof-ieee.c
/home/fedora-bootstrap/rpmbuild/BUILD/binutils-2.24/gas/config/tc-i386.c: In function 'build_modrm_byte':
/home/fedora-bootstrap/rpmbuild/BUILD/binutils-2.24/gas/config/tc-i386.c:6143:31: error: logical not is only applied to the left hand side of comparison [-Werror=logical-not-parentheses]
         && !op.bitfield.reg64 != 1
                               ^
----

Tha attached patch fixes that.

Version-Release number of selected component (if applicable):
binutils-2.24-30.fc21

How reproducible:
always
Comment 1 Jaromír Cápík 2015-05-22 06:13:05 EDT
Created attachment 1028680 [details]
binutils-2.24-i386-logical-not.patch
Comment 3 Jaromír Cápík 2015-05-22 07:00:38 EDT
Ahoj Marku.

I only fixed the FTBFS. The patch from Alan Modra is a superset of my fix and should do the same job. However the Alan's code looks cleaner, so ... I'm ok with backport :]
Comment 4 Nick Clifton 2015-05-28 08:41:36 EDT
Hi Guys,

I have added Alan's patch to the F21 sources (binutils-2.24-32.fc21.src.rpm).  The patch is not needed for F22 or later as the change is already in the binutils tarball.

Cheers
  Nick
Comment 5 Jaromír Cápík 2015-05-28 09:04:48 EDT
Hello Nick.
Would you mind building it + pushing to testing? You don't need to push it to stable. Our builders pull stuff from updates-testing.
Thanks,
Jaromir.
Comment 6 Nick Clifton 2015-05-28 09:23:55 EDT
Hi Jaromir,

  Done... :-)

Cheers
  Nick
Comment 7 Jaromír Cápík 2015-06-11 11:17:33 EDT
Hi Nick. I believe we can close this one. Thanks, Jaromir.

Note You need to log in before you can comment on or make changes to this bug.