Bug 1224241 - gfapi: zero size issue in glfs_h_acl_set()
Summary: gfapi: zero size issue in glfs_h_acl_set()
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Niels de Vos
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks: glusterfs-3.7.1
TreeView+ depends on / blocked
 
Reported: 2015-05-22 11:17 UTC by Niels de Vos
Modified: 2015-06-02 08:24 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-02 08:03:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2015-05-22 11:17:52 UTC
Description of problem:
When setting the stringified ACLs in the xattr dict through pub_glfs_h_setxattrs(), the size of the string is always passed as 0. The correct way is to pass the length of the ACL in text form.

Version-Release number of selected component (if applicable):
3.7.0

Additional information:
This needs a backport of mainline patch http://review.gluster.org/10782 (originally filed as a Coverity fix)

Comment 1 Anand Avati 2015-05-22 11:22:07 UTC
REVIEW: http://review.gluster.org/10890 (gfapi: zero size issue in glfs_h_acl_set()) posted (#1) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)

Comment 2 Anand Avati 2015-05-23 08:37:03 UTC
REVIEW: http://review.gluster.org/10890 (gfapi: zero size issue in glfs_h_acl_set()) posted (#2) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)

Comment 3 Anand Avati 2015-05-25 13:07:38 UTC
REVIEW: http://review.gluster.org/10890 (gfapi: zero size issue in glfs_h_acl_set()) posted (#3) for review on release-3.7 by jiffin tony Thottan (jthottan@redhat.com)

Comment 4 Anand Avati 2015-05-30 11:34:10 UTC
REVIEW: http://review.gluster.org/10890 (gfapi: zero size issue in glfs_h_acl_set()) posted (#4) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)

Comment 5 Anand Avati 2015-06-01 09:20:31 UTC
COMMIT: http://review.gluster.org/10890 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit a25529a0980b17567060eae8b40524381ca025d3
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri May 22 13:20:06 2015 +0200

    gfapi: zero size issue in glfs_h_acl_set()
    
    When setting the stringified ACLs in the xattr dict through
    pub_glfs_h_setxattrs(), the size of the string is always passed as 0.
    The correct way is to pass the length of the ACL in text form.
    
    Backport of:
    > Change-Id: Ia7a7fa1f3a7d615a813c703057dc97b09a0bbb34
    > BUG: 789278
    > Reviewd-on: http://review.gluster.org/10782
    > Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com>
    
    Change-Id: Ia7a7fa1f3a7d615a813c703057dc97b09a0bbb34
    BUG: 1224241
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/10890
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 6 Niels de Vos 2015-06-02 08:03:09 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.1, please reopen this bug report.

glusterfs-3.7.1 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/1
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.