Bug 1224248 - [UX] Error message doesn't show names of packages well
Summary: [UX] Error message doesn't show names of packages well
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 22
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: packaging-team-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-22 11:24 UTC by Martin Bašti
Modified: 2015-08-19 07:51 UTC (History)
7 users (show)

Fixed In Version: dnf-plugins-core-0.1.10-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-15 02:13:51 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Bašti 2015-05-22 11:24:34 UTC
Description of problem:
The error message doesn't show particular packages well.

Version-Release number of selected component (if applicable):
dnf-1.0.0-1.fc22.noarch

How reproducible:
Always

Steps to Reproduce:
1. modify /etc/resolv.conf with IP address of nonworking name server (or localhost)
2. dnf upgrade
3. 

Actual results:
[FAILED] kernel-modules-4.0.4-301.fc22.x86_64.rpm: No more mirrors to try - All mirrors were already tried without success                                                                                        
Error: Error downloading packages:86_64.rpm                                             5% [====-                                                                                ]  23 GB/s |  18 MB     00:00 ETA
  Cannot download k/kernel-modules-4.0.4-301.fc22.x86_64.rpm: All mirrors were tried



Expected results:
Error: Error downloading packages:                      
  Cannot download kernel-modules-4.0.4-301.fc22.x86_64.rpm: All mirrors were tried
  Cannot download kernel-core-4.0.4-301.fc22.x86_64.rpm: All mirrors were tried
  Cannot download kernel-4.0.4-301.fc22.x86_64.rpm: All mirrors were tried


Additional info:
This bug is applicable for yum as well, and for F21 too

Comment 1 Fedora Update System 2015-08-10 10:05:50 UTC
dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc23,dnf-1.1.0-1.fc23,hawkey-0.6.0-1.fc23

Comment 2 Fedora Update System 2015-08-10 10:49:53 UTC
dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22

Comment 3 Fedora Update System 2015-08-11 02:11:05 UTC
Package dnf-plugins-core-0.1.10-1.fc22, dnf-1.1.0-1.fc22, hawkey-0.6.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.10-1.fc22 dnf-1.1.0-1.fc22 hawkey-0.6.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-13162/dnf-plugins-core-0.1.10-1.fc22,dnf-1.1.0-1.fc22,hawkey-0.6.0-1.fc22
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2015-08-15 02:13:51 UTC
dnf-plugins-core-0.1.10-1.fc22, hawkey-0.6.0-1.fc22, dnf-1.1.0-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2015-08-19 07:51:38 UTC
dnf-plugins-core-0.1.10-1.fc23, hawkey-0.6.0-1.fc23, dnf-1.1.0-2.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.