Bug 1224261 - [abrt] deluge-gtk: createtorrentdialog.py:118:parse_piece_size_text:ValueError: need more than 1 value to unpack
Summary: [abrt] deluge-gtk: createtorrentdialog.py:118:parse_piece_size_text:ValueErro...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: deluge
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Cronenworth
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:4f7e24a42a49d4f51993aa421bc...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-22 12:13 UTC by Tutul
Modified: 2015-09-03 18:50 UTC (History)
4 users (show)

Fixed In Version: 1.3.11-5.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-03 10:04:08 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (789 bytes, text/plain)
2015-05-22 12:13 UTC, Tutul
no flags Details
File: environ (1.69 KB, text/plain)
2015-05-22 12:13 UTC, Tutul
no flags Details

Description Tutul 2015-05-22 12:13:43 UTC
Description of problem:
Just trying to create a torrent from a directory with 2 Go of videos. Crash when I select the directory

Version-Release number of selected component:
deluge-gtk-1.3.11-1.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        deluge-gtk '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' '' ''
executable:     /usr/bin/deluge-gtk
kernel:         3.19.7-200.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
createtorrentdialog.py:118:parse_piece_size_text:ValueError: need more than 1 value to unpack

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/createtorrentdialog.py", line 194, in _on_button_folder_clicked
    self.adjust_piece_size()
  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/createtorrentdialog.py", line 134, in adjust_piece_size
    psize = self.parse_piece_size_text(value[0])
  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/createtorrentdialog.py", line 118, in parse_piece_size_text
    psize, metric = value.split()
ValueError: need more than 1 value to unpack

Local variables in innermost frame:
self: <deluge.ui.gtkui.createtorrentdialog.CreateTorrentDialog instance at 0x7ff9c2bba908>
value: '32\xc2\xa0KiB'

Comment 1 Tutul 2015-05-22 12:13:45 UTC
Created attachment 1028724 [details]
File: backtrace

Comment 2 Tutul 2015-05-22 12:13:46 UTC
Created attachment 1028725 [details]
File: environ

Comment 3 Michael Cronenworth 2015-05-22 14:35:45 UTC
I cannot reproduce this. I can create torrents by selecting directories.

Are you checking any of the option boxes in the create torrent dialog?

Comment 4 Tutul 2015-05-22 14:49:04 UTC
No, I just click on "Directory" button, selected the desired directory and the error was here. NB : deluge stay open and the frame for create a torrent still there but not working any more. The directory contains 13 avi files for a total of ~2,8 Go. I have the problems 3 time and must install and use Transmission to create my torrent. (by the way, no problem on windows version of deluge)

I'm at your service to provides more informations (maybe laucnh deluge in a terminal to see the error). But now I'm not on the good computer...

Comment 5 Tutul 2015-06-01 12:06:10 UTC
I try to get more information using debug loglevel, but I have no more usefull informations. Do you want to have a short video (screencast) to show what I exactly do ? (it's exactly what I've put in the previous commant)

Comment 6 Michael Cronenworth 2015-06-01 18:55:56 UTC
Sure, make a video.

Comment 7 Tutul 2015-06-02 12:25:22 UTC
Sorry, it's use youtube because I cannot add infos on video. You can see all my manipulation to te error. https://www.youtube.com/watch?v=v3VoM7xPidU

Comment 8 foudfou 2015-08-20 18:45:41 UTC
The french translation has non-breakable spaces for the 'combo_piece_size' dialog strings, like '64\xc2\xa0KiB', which can't be .split()'ed.

The workaround is to launch deluge like: LANG=C deluge &

Mike, who can correct that ?

Comment 9 Fedora Update System 2015-08-22 04:42:10 UTC
deluge-1.3.11-5.fc23 has been submitted as an update to Fedora 23. https://bugzilla.redhat.com/show_bug.cgi?id=1224261

Comment 10 Michael Cronenworth 2015-08-22 04:42:31 UTC
Ah... thanks for the pointer. I should have noticed this was an encoding issue.

Please try the builds I am pushing to testing and leave feedback if it's fixed.

This was also reported upstream, but they ended up fixing the French translation where my patch will fix it for any translation.

http://dev.deluge-torrent.org/ticket/2757

I posted a message on the forum with my patches.

http://forum.deluge-torrent.org/viewtopic.php?f=8&t=52103

Comment 11 Fedora Update System 2015-08-22 04:46:59 UTC
deluge-1.3.11-5.fc22 has been submitted as an update to Fedora 22. https://bugzilla.redhat.com/show_bug.cgi?id=1224261

Comment 12 Fedora Update System 2015-08-22 04:50:38 UTC
deluge-1.3.11-5.fc21 has been submitted as an update to Fedora 21. https://bugzilla.redhat.com/show_bug.cgi?id=1224261

Comment 13 Fedora Update System 2015-08-23 01:49:06 UTC
deluge-1.3.11-5.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update deluge'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13972

Comment 14 Fedora Update System 2015-08-23 01:49:58 UTC
deluge-1.3.11-5.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update deluge'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13973

Comment 15 Fedora Update System 2015-08-23 01:50:33 UTC
deluge-1.3.11-5.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update deluge'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13971

Comment 16 Fedora Update System 2015-09-03 10:04:06 UTC
deluge-1.3.11-5.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2015-09-03 18:49:37 UTC
deluge-1.3.11-5.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2015-09-03 18:50:06 UTC
deluge-1.3.11-5.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.