Bug 1224294 - perl-OpenGL-0.6702-4.fc23 FTBFS: undefined symbol: glWindowPos4dMESA
Summary: perl-OpenGL-0.6702-4.fc23 FTBFS: undefined symbol: glWindowPos4dMESA
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-OpenGL
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: http://koji.fedoraproject.org/koji/ta...
Whiteboard:
Depends On: 1224738
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-22 13:12 UTC by Petr Pisar
Modified: 2015-06-08 15:31 UTC (History)
4 users (show)

Fixed In Version: perl-OpenGL-0.6704-1.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-08 15:31:49 UTC


Attachments (Terms of Use)

Description Petr Pisar 2015-05-22 13:12:07 UTC
perl-OpenGL-0.6702-4.fc23 fails to build in F23 because tests fail on linking with Mesa OpenGL library:

+ make test
"/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
#   Failed test 'require OpenGL;'
#   at t/00_require.t line 3.
#     Tried to require 'OpenGL'.
#     Error:  Can't load '/builddir/build/BUILD/OpenGL-0.6702/blib/arch/auto/OpenGL/OpenGL.so' for module OpenGL: /builddir/build/BUILD/OpenGL-0.6702/blib/arch/auto/OpenGL/OpenGL.so: undefined symbol: glWindowPos4dMESA at /usr/lib64/perl5/DynaLoader.pm line 193.
#  at (eval 4) line 2.
# Compilation failed in require at (eval 4) line 2.
# Looks like you failed 1 test of 1.
t/00_require.t ....... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests

This is caused by upgrading mesa-libGL-devel from 10.6.0-0.devel.5.51e3453 to 10.6.0-0.devel.6.5a55f68.


Note You need to log in before you can comment on or make changes to this bug.