Bug 1224349 - with systemd-220 a number of systemctl commands are denied
Summary: with systemd-220 a number of systemctl commands are denied
Keywords:
Status: CLOSED DUPLICATE of bug 1224211
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-22 15:34 UTC by Kevin Fenzi
Modified: 2015-05-22 16:34 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-22 16:34:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Kevin Fenzi 2015-05-22 15:34:25 UTC
After upgrading to systemd-220-1.fc23.x86_64 a number of systemctl commands now give permission denied:

# systemctl list-unit-files
Failed to list unit files: Access denied

AVC: 

type=USER_AVC msg=audit(1432308400.210:4441): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='avc:  denied  { status } for auid=1000 uid=0 gid=0 cmdline="systemctl list-unit-files" scontext=system_u:object_r:unlabeled_t:s0 tcontext=system_u:system_r:init_t:s0 tclass=system  exe="/usr/lib/systemd/systemd" sauid=0 hostname=? addr=? terminal=?'

Happy to gather more info or try things. Perhaps something moved in systemd-220 and is no longer labeled correctly?

Comment 1 Kevin Fenzi 2015-05-22 15:38:16 UTC
This might be a systemd bug, fixed by: 

http://cgit.freedesktop.org/systemd/systemd/commit/?id=b860a90ea5afd2da57225195c1cb7edd64a8b73d

Comment 2 Zbigniew Jędrzejewski-Szmek 2015-05-22 16:32:47 UTC
That commit is in 220, so it cannot be the fix.

> Perhaps something moved in systemd-220 and is no longer labeled correctly?
No, nothing related moved.

Comment 3 Kevin Fenzi 2015-05-22 16:34:51 UTC
Moving this over to 1224211 as it was filed before this one and has some more info.

*** This bug has been marked as a duplicate of bug 1224211 ***


Note You need to log in before you can comment on or make changes to this bug.