Bug 1224362 - [RFE] provide convenient function to handle services of super server (xinetd)
Summary: [RFE] provide convenient function to handle services of super server (xinetd)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: beakerlib
Version: rawhide
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dalibor Pospíšil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 917501 1258483 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-22 16:22 UTC by Marek Haicman
Modified: 2015-12-08 08:45 UTC (History)
8 users (show)

Fixed In Version: beakerlib-1.11-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-08 08:45:05 UTC


Attachments (Terms of Use)
Proposed implementation (32.71 KB, patch)
2015-06-23 10:48 UTC, Marek Haicman
no flags Details | Diff
Updated patch (32.70 KB, patch)
2015-06-23 13:02 UTC, Marek Haicman
no flags Details | Diff

Description Marek Haicman 2015-05-22 16:22:06 UTC
Description of problem:
BeakerLib has convenience functions to work with services. But those services controlled by super server, for example rsh have to be started or stopped manually.

It would be great, if rlService{Start,Stop,Restore} [or new set of functions] could handle these as well.

Comment 1 Ales Zelinka 2015-06-16 12:11:15 UTC
Dalibor, do you plan to extend existing rlService or implement new set of sunctions? New functions would be easier to implement (e.g. no need to solve conflicts between system and xinetd service names) but xinetd is IMO going the way of dodo, being replaced by systemd so I'm not usre it's worth it.

Comment 2 Marek Haicman 2015-06-16 12:39:28 UTC
Hi Ales, I respond, as I am supposed to implement this.

It will be new set of functions, as it could be tricky to decide if user wants to handle standalone service, or server [socket in systemd world].

And as socket handling in rhel7 is not covered by existing library functions either and will be part of this solution, these functions will get their share of use.

Comment 3 Dalibor Pospíšil 2015-06-16 12:45:24 UTC
Moreover there should be also general functions for enabling / disabling / restoring of services. These would be used on RHEL<=6.

Comment 4 Marek Haicman 2015-06-23 10:48:29 UTC
Created attachment 1042233 [details]
Proposed implementation

Comment 5 Marek Haicman 2015-06-23 13:02:50 UTC
Created attachment 1042310 [details]
Updated patch

Fixed small flaw in test part. Now the patch should be OK.

Comment 6 Dalibor Pospíšil 2015-08-31 13:30:51 UTC
*** Bug 1258483 has been marked as a duplicate of this bug. ***

Comment 9 Ales Zelinka 2015-10-20 15:17:59 UTC
*** Bug 917501 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2015-11-03 12:41:53 UTC
beakerlib-1.11-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-f36ff57e84

Comment 12 Fedora Update System 2015-11-03 18:21:08 UTC
beakerlib-1.11-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update beakerlib'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4c96e73472

Comment 13 Fedora Update System 2015-11-03 18:56:32 UTC
beakerlib-1.11-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update beakerlib'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ba802d1bd6

Comment 14 Fedora Update System 2015-11-03 19:52:37 UTC
beakerlib-1.11-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update beakerlib'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-7ab9feeb42

Comment 15 Fedora Update System 2015-11-03 21:50:25 UTC
beakerlib-1.11-1.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update beakerlib'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-0e03df1475

Comment 16 Fedora Update System 2015-11-05 17:19:32 UTC
beakerlib-1.11-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update beakerlib'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-8f65d5290a

Comment 17 Fedora Update System 2015-11-05 20:18:27 UTC
beakerlib-1.11-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update beakerlib'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-f36ff57e84

Comment 18 Fedora Update System 2015-11-17 15:52:11 UTC
beakerlib-1.11-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2015-11-17 18:24:02 UTC
beakerlib-1.11-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2015-11-19 16:50:19 UTC
beakerlib-1.11-1.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2015-11-20 23:25:06 UTC
beakerlib-1.11-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2015-11-21 14:26:20 UTC
beakerlib-1.11-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2015-11-21 20:30:13 UTC
beakerlib-1.11-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.