Bug 122445 - anaconda crashes on install after manual disk partition with attached lvm array
anaconda crashes on install after manual disk partition with attached lvm array
Status: CLOSED DUPLICATE of bug 116289
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 12:47 EDT by Steve Chaffee
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog from crashed install (10.12 KB, text/plain)
2004-05-04 12:53 EDT, Steve Chaffee
no flags Details

  None (edit)
Description Steve Chaffee 2004-05-04 12:47:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; 
Agilent Technologies IE5.5 SP2)

Description of problem:
Install ws 3 on a dual-xeon nfs/samba file server. Manually 
partition  to ensure adequate swap space (4g ram and swap for rsync). 
Has a scsi array hanging off it that has been lvm'd but is not 
changed in the partitioning. proceed with package selection and off 
it goes to check dependencies. Warns that there is an invalid 
argument to /dev/sdb4 - one of the UNCHANGED lvs. Hit ignore or 
cancel and anaconda crashes. Error file written to floppy is attached

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.manually partition /dev/sda, leaving scsi (lvm)array /dev/sdb alone
2.continue to select packages
3.watch anaconda crash
    

Actual Results:  Anaconda crashes, says safe to reboot - but install 
is not functional or repairable

Expected Results:  should be no change to sdb4, should finish install 
without changes, and boot into ws

Additional info:

attachments coming
Comment 1 Steve Chaffee 2004-05-04 12:52:42 EDT
crash dump attached
Comment 2 Steve Chaffee 2004-05-04 12:53:17 EDT
Created attachment 99961 [details]
syslog from crashed install
Comment 3 Jeremy Katz 2004-05-06 18:31:52 EDT
Device that's larger than 1TB?
Comment 4 Steve Chaffee 2004-05-06 21:10:29 EDT
yes. Device is split via lvm into 3 volumes of 474G each, with about 
250G left as spare for future growth - i.e. no lv created for the 
spare.
Comment 5 Jeremy Katz 2004-06-09 17:45:57 EDT

*** This bug has been marked as a duplicate of 116289 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:02:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.