Bug 122446 - Copy message(s) to dialog box unresponsive to keyboard input
Copy message(s) to dialog box unresponsive to keyboard input
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 12:59 EDT by Colin Charles
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 12:42:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Charles 2004-05-04 12:59:02 EDT
Description of problem: Copy message(s) to dialog box doesn't work as
it should be, obeying keyboard commands, where once you're in the
dialog, hitting a key on the keyboard (say the "f" key), should scroll
to folders that begin with "f"


Version-Release number of selected component (if applicable):
evolution-1.4.5-7

How reproducible: Always


Steps to Reproduce:
1. Select a message, then right click it
2. Select Copy to Folder
3. At the pop-up, let's say you have a folder named "fedora" and
another named "gnome", try hitting the "g" key, and it will go nowhere. 
4. To move it to the "gnome" folder, you have to scroll thru the
entire list, before clicking on it with the mouse
  
Actual results:
Keyboard input does nothing

Expected results:
Keyboard input of said character should move to the next folder
available, starting with the input character. So assuming there's a
"gnome" and a "godzilla" folder, it should go to one first, then
scroll to the other, providing options - you don't have to use the
mouse for this!

Additional info:
Works on Evolution that's not included in Fedora, so this looks like
some Fedora non-compliance - GNOME's HIG does state keyboard access is
important
Comment 1 Colin Charles 2004-05-07 12:42:02 EDT
Fixed in evolution-1.4.6-1

Note You need to log in before you can comment on or make changes to this bug.