This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 122449 - [PATCH] xscreensaver packages broken - core dump
[PATCH] xscreensaver packages broken - core dump
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xscreensaver (Show other bugs)
3.0
ia32e Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
Depends On:
Blocks: 116727
  Show dependency treegraph
 
Reported: 2004-05-04 13:15 EDT by Kim Jensen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-27 17:21:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kim Jensen 2004-05-04 13:15:49 EDT
Description of problem:
/usr/X11R6/lib/xscreensaver/[lament|sproingies] core dump 

Bad NULL pointer (wrong size - not correctly promoted to 0L 
as expected) for call to XtVaAppCreateShell(..., 0L) 

Reason is same old nemisis we found for IA64 (my patch below): 
--- xscreensaver-4.10/hacks/screenhack.c.orig  2002-09-23 
02:30:37.000000000 -0600 
+++ xscreensaver-4.10/hacks/screenhack.c        2004-04-30 
21:42:57.000000000 -0600 
@@ -592,7 +592,7 @@ 
                                    XtNbackground, (Pixel) bg, 
                                    XtNborderColor, (Pixel) bd, 
                                    XtNinput, True,  /* for WM_HINTS 
*/ 
-                                  0); 
+                                  0L); 
          XtDestroyWidget (toplevel); 
          toplevel = new; 
          XtRealizeWidget (toplevel); 


Version-Release number of selected component (if applicable):
xscreensaver-4.10-4

How reproducible:
Everytime

Steps to Reproduce:
1. Install RHEL3U2 "RC" (2.4.21-14 kernel)
2. Bring up X (w/ vesa driver)
3. Run lament or sproingies
  
Actual results:
Core dump due to pointer that has not been promoted to 0L

Expected results:
screensaver runs w/o core dump

Additional info:
We have tested the patch and it fixes the problem.  Also, this was a 
problem that was perviously fixed in the ia64 bits.
Comment 3 Ray Strode [halfline] 2004-06-24 17:23:12 EDT
Marking MODIFIED while QA tests the fix.
Comment 4 Kim Jensen 2004-08-27 17:21:12 EDT
Verified as fixed in RHEL3U3 WS x86-64 Public Beta.  Thanks.
Comment 5 Jay Turner 2004-09-01 22:26:13 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-257.html

Note You need to log in before you can comment on or make changes to this bug.