Bug 122450 - BCM5700 driver hangs tcpip (tg3.ko not OK)
BCM5700 driver hangs tcpip (tg3.ko not OK)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 13:20 EDT by Pierre MENGA
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-04 13:23:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file of DELL PowerEdge 2550 (46.68 KB, text/plain)
2004-05-05 03:14 EDT, Pierre MENGA
no flags Details

  None (edit)
Description Pierre MENGA 2004-05-04 13:20:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b)
Gecko/20040414 Firefox/0.8.0+ (MozJF)

Description of problem:
the broadcom GigaBit BCM 5700 is installed with tigon tg3.ko but hangs
the complete network process. 
I installed the sources from BroadCom (bcm5700-7.1.22) but when
compiling, I have the following error:
*** warning: "genapic" undefined"
and when testing with "insmod bcm5700.ko":
insmod: error inserting 'bcm5700.ko": -1 Unknown symobol in module

So how should Fedora recognize my BCM5700 card ?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install linux bcm5700-7.1.22.tar.gz sources
2. make 
3. insmod bcm5700.ko
    

Additional info:
Comment 1 Arjan van de Ven 2004-05-04 13:23:19 EDT
tg3 should work but please file a separate bug about that
the bcm5700 driver not working is NOTOURBUG...
Comment 2 Pierre MENGA 2004-05-05 03:14:52 EDT
Created attachment 99985 [details]
log file of DELL PowerEdge 2550
Comment 3 Pierre MENGA 2004-05-05 03:23:52 EDT
I do insist; tg3 looks as if it works (it is load vis insmod, ifconfig
marks eth1 as UP, but no ping to the another machine. I have two
ethernet cards (e100 and bcm5700).
* When e100 is loaded, everything is OK
* When tg3 is loaded, no net
* When e100 and tg3 are loaded, non net. A t that time, I do a
'ifcongig eth1 down' and everything is OK

note: I posted an message.log file which shows the init of th Dell
PowerEdge 2550. (there's also an agpart-serverworks error (-22), which
makes my Xwindows looks like a 640x480 vga, but for a server, this is
not critical)


eth1      Lien encap:Ethernet  HWaddr 00:B0:D0:DE:6D:A3  
          inet adr:192.9.200.5  Bcast:192.9.207.255  Masque:255.255.240.0
          adr inet6: fe80::2b0:d0ff:fede:6da3/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          RX bytes:0 (0.0 b)  TX bytes:1806 (1.7 Kb)
          Interruption:233 

Note You need to log in before you can comment on or make changes to this bug.