Bug 1224516 - Review Request: httpcomponents-asyncclient - Apache components to build asynchronous client side HTTP services
Summary: Review Request: httpcomponents-asyncclient - Apache components to build async...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eduardo Mayorga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1245633
TreeView+ depends on / blocked
 
Reported: 2015-05-23 23:34 UTC by gil cattaneo
Modified: 2015-08-07 13:10 UTC (History)
2 users (show)

Fixed In Version: httpcomponents-asyncclient-4.1-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-07 13:10:53 UTC
e: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description gil cattaneo 2015-05-23 23:34:04 UTC
Spec URL: https://gil.fedorapeople.org/httpcomponents-asyncclient.spec
SRPM URL: https://gil.fedorapeople.org/httpcomponents-asyncclient-4.1-1.fc20.src.rpm
Description: Apache components to build asynchronous client side HTTP services.

metrics 3.1.2 dependency

Fedora Account System Username: gil

Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=9835895

Comment 1 gil cattaneo 2015-05-31 13:21:34 UTC
Spec URL: https://gil.fedorapeople.org/httpcomponents-asyncclient.spec
SRPM URL: https://gil.fedorapeople.org/httpcomponents-asyncclient-4.1-1.fc20.src.rpm
Description:
Asynch HttpClient is a HTTP/1.1 compliant HTTP agent implementation based on
HttpCore NIO and HttpClient components. It is a complementary module to
Apache HttpClient intended for special cases where ability to handle
a great number of concurrent connections is more important than performance
in terms of a raw data throughput.

Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=9897826

Comment 3 Eduardo Mayorga 2015-07-26 01:36:28 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated


Issues:
=======
- Version 4.5 is available.
- -cache subpackage does not include license text.

===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
[!]: License file installed when any subpackage combination is installed.
[x]: Package does not own files or directories owned by other packages.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 20480 bytes in 2 files.
[!]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

Java:
[x]: Bundled jar/class files should be removed before build
[x]: Packages have proper BuildRequires/Requires on jpackage-utils
     Note: Maven packages do not need to (Build)Require jpackage-utils. It
     is pulled in by maven-local
[x]: Javadoc documentation files are generated and included in -javadoc
     subpackage
[x]: Javadoc subpackages should not have Requires: jpackage-utils
[x]: Javadocs are placed in %{_javadocdir}/%{name} (no -%{version} symlink)

Maven:
[x]: If package contains pom.xml files install it (including metadata) even
     when building with ant
[x]: POM files have correct Maven mapping
[x]: Maven packages should use new style packaging
[x]: Old add_to_maven_depmap macro is not being used
[x]: Packages DO NOT have Requires(post) and Requires(postun) on jpackage-
     utils for %update_maven_depmap macro
[x]: Package DOES NOT use %update_maven_depmap in %post/%postun
[x]: Packages use .mfiles file list instead of %{_datadir}/maven2/poms

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[-]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in
     httpcomponents-asyncclient-cache , httpcomponents-asyncclient-parent ,
     httpcomponents-asyncclient-javadoc
[?]: Package functions as described.
[!]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

Java:
[x]: Package uses upstream build method (ant/maven/etc.)
[x]: Packages are noarch unless they use JNI

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: httpcomponents-asyncclient-4.1-1.fc24.noarch.rpm
          httpcomponents-asyncclient-cache-4.1-1.fc24.noarch.rpm
          httpcomponents-asyncclient-parent-4.1-1.fc24.noarch.rpm
          httpcomponents-asyncclient-javadoc-4.1-1.fc24.noarch.rpm
          httpcomponents-asyncclient-4.1-1.fc24.src.rpm
httpcomponents-asyncclient.noarch: W: spelling-error %description -l en_US Asynch -> Asynchronous
httpcomponents-asyncclient-cache.noarch: W: no-documentation
httpcomponents-asyncclient-parent.noarch: W: no-documentation
httpcomponents-asyncclient.src: W: spelling-error %description -l en_US Asynch -> Asynchronous
5 packages and 0 specfiles checked; 0 errors, 4 warnings.




Rpmlint (installed packages)
----------------------------
httpcomponents-asyncclient.noarch: W: invalid-url URL: http://hc.apache.org/ <urlopen error [Errno -5] No address associated with hostname>
httpcomponents-asyncclient-javadoc.noarch: W: invalid-url URL: http://hc.apache.org/ <urlopen error [Errno -5] No address associated with hostname>
httpcomponents-asyncclient-parent.noarch: W: invalid-url URL: http://hc.apache.org/ <urlopen error [Errno -5] No address associated with hostname>
httpcomponents-asyncclient-parent.noarch: W: no-documentation
httpcomponents-asyncclient-cache.noarch: W: invalid-url URL: http://hc.apache.org/ <urlopen error [Errno -5] No address associated with hostname>
httpcomponents-asyncclient-cache.noarch: W: no-documentation
4 packages and 0 specfiles checked; 0 errors, 6 warnings.



Requires
--------
httpcomponents-asyncclient (rpmlib, GLIBC filtered):
    java-headless
    jpackage-utils
    mvn(commons-logging:commons-logging)
    mvn(org.apache.httpcomponents:httpclient)
    mvn(org.apache.httpcomponents:httpcore)
    mvn(org.apache.httpcomponents:httpcore-nio)

httpcomponents-asyncclient-javadoc (rpmlib, GLIBC filtered):
    jpackage-utils

httpcomponents-asyncclient-parent (rpmlib, GLIBC filtered):
    java-headless
    jpackage-utils
    mvn(org.apache.httpcomponents:project:pom:)
    mvn(org.apache.maven.plugins:maven-jar-plugin)
    mvn(org.apache.maven.plugins:maven-javadoc-plugin)

httpcomponents-asyncclient-cache (rpmlib, GLIBC filtered):
    java-headless
    jpackage-utils
    mvn(org.apache.httpcomponents:httpasyncclient)
    mvn(org.apache.httpcomponents:httpclient-cache)



Provides
--------
httpcomponents-asyncclient:
    httpcomponents-asyncclient
    mvn(org.apache.httpcomponents:httpasyncclient)
    mvn(org.apache.httpcomponents:httpasyncclient:pom:)
    osgi(org.apache.httpcomponents.httpasyncclient)

httpcomponents-asyncclient-javadoc:
    httpcomponents-asyncclient-javadoc

httpcomponents-asyncclient-parent:
    httpcomponents-asyncclient-parent
    mvn(org.apache.httpcomponents:httpcomponents-asyncclient:pom:)

httpcomponents-asyncclient-cache:
    httpcomponents-asyncclient-cache
    mvn(org.apache.httpcomponents:httpasyncclient-cache)
    mvn(org.apache.httpcomponents:httpasyncclient-cache:pom:)
    osgi(org.apache.httpcomponents.httpasyncclient-cache)



Source checksums
----------------
http://www.apache.org/dist/httpcomponents/httpasyncclient/source/httpcomponents-asyncclient-4.1-src.tar.gz :
  CHECKSUM(SHA256) this package     : f787407f3aa1cdd890a54e2c90b188658bfde27123d951399c94411893a585cf
  CHECKSUM(SHA256) upstream package : f787407f3aa1cdd890a54e2c90b188658bfde27123d951399c94411893a585cf

Comment 4 gil cattaneo 2015-07-26 08:25:51 UTC
(In reply to Eduardo Mayorga from comment #3)

> Issues:
> =======
> - Version 4.5 is available.
> [!]: Latest version is packaged.
this is version is only available for httpcomponents-client
http://mirrors.muzzy.it/apache//httpcomponents/httpclient/source/httpcomponents-client-4.5-src.tar.gz
see http://hc.apache.org/downloads.cgi

> - -cache subpackage does not include license text.
> [!]: License file installed when any subpackage combination is installed.
Fixed
> [!]: Package complies to the Packaging Guidelines
i don't understand this. please, can you explain to me what is the problem?


Spec URL: https://gil.fedorapeople.org/httpcomponents-asyncclient.spec
SRPM URL: https://gil.fedorapeople.org/httpcomponents-asyncclient-4.1-2.fc22.src.rpm

- add, also for cache sub-package, license and notice files

Comment 5 Eduardo Mayorga 2015-07-26 19:11:56 UTC
(In reply to gil cattaneo from comment #4)
> (In reply to Eduardo Mayorga from comment #3)
> > [!]: Package complies to the Packaging Guidelines
> i don't understand this. please, can you explain to me what is the problem?

I set fails because of the above issue on licensing.

Comment 6 Eduardo Mayorga 2015-07-26 19:54:53 UTC
Now it looks fine.

PACKAGE APPROVED

Comment 7 gil cattaneo 2015-07-26 20:04:25 UTC
Thanks!

New Package SCM Request
=======================
Package Name: httpcomponents-asyncclient
Short Description: Apache components to build asynchronous client side HTTP services
Upstream URL: http://hc.apache.org/
Owners: gil
Branches: f22 f23
InitialCC: java-sig

Comment 8 Gwyn Ciesla 2015-07-27 19:13:04 UTC
Git done (by process-git-requests).

Comment 9 Fedora Update System 2015-07-27 21:01:47 UTC
httpcomponents-asyncclient-4.1-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/httpcomponents-asyncclient-4.1-2.fc22

Comment 10 Fedora Update System 2015-07-30 00:45:47 UTC
httpcomponents-asyncclient-4.1-2.fc22 has been pushed to the Fedora 22 testing repository.

Comment 11 Fedora Update System 2015-08-07 13:10:53 UTC
httpcomponents-asyncclient-4.1-2.fc22 has been pushed to the Fedora 22 stable repository.


Note You need to log in before you can comment on or make changes to this bug.