Bug 12246 - RFE:Handle exceptions related to /etc/fstab entries more gracefully
Summary: RFE:Handle exceptions related to /etc/fstab entries more gracefully
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-14 09:36 UTC by Jonathan Kamens
Modified: 2007-04-18 16:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-02 21:13:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2000-06-14 09:36:52 UTC
When I tried to do a text-based ugprade from 6.2 to Winston, I got this
error message while it was checking for previous installations: "Error
mounting hde5: block device required", then an anaconda traceback and the
installer gave up.

This is probably because hde is on a promise IDE controller whose driver is
not built into the kernel.  I suspect that when the default IDE driver is
used to access the promise IDE card, it can't handle old IDE drives (hde is
a very old drive), whereas it can handle such drives when the promise
driver is used.

Perhaps anaconda should display warnings, not fatal errors, when it can't
mount a filesystem that's listed in /etc/fstab.

Comment 1 Michael Fulbright 2000-06-14 14:09:19 UTC
This feature will be added to our list of requests.

Comment 2 Jonathan Kamens 2000-06-15 01:06:10 UTC
This is not a "feature."  It is a bug.  I have a valid RedHat installation and
yet I cannot use the RedHat upgrade process because of this problem.  Yes, there
is a workaround (I can comment out hde in /etc/fstab before rebooting to do the
upgrade), but that doesn't change the fact that this is a bug and should be
treated as such.



Note You need to log in before you can comment on or make changes to this bug.