Bug 1224600 - [RFE] Move signing trigger mechanism to [f]setxattr()
Summary: [RFE] Move signing trigger mechanism to [f]setxattr()
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: bitrot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Venky Shankar
QA Contact:
bugs@gluster.org
URL:
Whiteboard:
Depends On:
Blocks: 1225709 1227198
TreeView+ depends on / blocked
 
Reported: 2015-05-25 05:44 UTC by Venky Shankar
Modified: 2016-06-16 13:04 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1225709 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:04:41 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Venky Shankar 2015-05-25 05:44:48 UTC
Description of problem:
Currently triggering signing for a file (explicit signing by bitd) is based on overloading writev(). This is a bit dangerous and not clean. Better to move it to setxattr() path (with a special key identified by bitd and stub).

Version-Release number of selected component (if applicable):
mainline

Comment 1 Anand Avati 2015-05-27 11:57:29 UTC
REVIEW: http://review.gluster.org/10942 (features/bitrot: stub improvements and fixes) posted (#1) for review on master by Venky Shankar (vshankar@redhat.com)

Comment 2 Venky Shankar 2015-05-28 11:35:33 UTC
patch merged in upstream master: http://review.gluster.org/#/c/10942/

don't know why the commit didn't update the bz.

Comment 3 Nagaprasad Sathyanarayana 2015-10-25 14:45:37 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 4 Niels de Vos 2016-06-16 13:04:41 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.