Bug 1224813 - instack-undercloud: running "instack-virt-setup" doesn't create the instack VM.
Summary: instack-undercloud: running "instack-virt-setup" doesn't create the instack VM.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: Director
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-25 21:28 UTC by Alexander Chuzhoy
Modified: 2015-08-05 13:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:51:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Alexander Chuzhoy 2015-05-25 21:28:06 UTC
instack-undercloud: running "instack-virt-setup" doesn't create the instack VM.

Environment:
instack-undercloud-2.1.1-dev15.el7.centos.noarch


Steps to reproduce:
Try to deploy undercloud on a VM setup.
Follow  the sphynx docs, run "instack-virt-setup"


Result:

--------------------- END PROFILING ---------------------
dib-run-parts Tue May 26 00:23:48 IDT 2015 Running /tmp/image.zjmskaEn/hooks/cleanup.d/01-ccache
dib-run-parts Tue May 26 00:23:48 IDT 2015 01-ccache completed
dib-run-parts Tue May 26 00:23:48 IDT 2015 Running /tmp/image.zjmskaEn/hooks/cleanup.d/01-copy-manifests-dir
+ set -eu
+ set -o pipefail
+ '[' -d /tmp/image.zjmskaEn/mnt//etc/dib-manifests ']'
+ '[' -e /tmp/image.zjmskaEn/mnt/etc/dib_arguments ']'
+ sudo mv /tmp/image.zjmskaEn/mnt/etc/dib_arguments /tmp/image.zjmskaEn/mnt//etc/dib-manifests
+ '[' -e /tmp/image.zjmskaEn/mnt/etc/dib_environment ']'
+ sudo mv /tmp/image.zjmskaEn/mnt/etc/dib_environment /tmp/image.zjmskaEn/mnt//etc/dib-manifests
+ mkdir -p instack.d/
mkdir: cannot create directory 'instack.d/': Permission denied
/dev/loop0: [0036]:166311 (/tmp/image.VETZmKdH/image.raw)



Running: virsh list --all shows:
 Id    Name                           State
----------------------------------------------------
 -     baremetal_0                    shut off
 -     baremetal_1                    shut off


Expected result:

The instack VM should be up and running.

Comment 3 James Slagle 2015-05-26 15:01:44 UTC
it appears you're using RDO packages. can you restest using RHOS only?

I've put up a review documenting how to do this:
https://review.gerrithub.io/#/c/234349/

Comment 4 Alexander Chuzhoy 2015-06-01 21:01:30 UTC
The issue doesn't reproduce now - using RHOS.

Comment 5 Mike Burns 2015-06-02 11:45:41 UTC
marking modified since it's fixed now.  Removing blocker since we're not supporting instack-virt-setup.

Comment 9 Alexander Chuzhoy 2015-06-19 15:58:07 UTC
Verified:

Environment:
instack-undercloud-2.1.2-1.el7ost.noarch

The issue doesn't reproduce now.

Comment 11 errata-xmlrpc 2015-08-05 13:51:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.