Bug 1224837 - python-paste-script-2.0.2 is available
python-paste-script-2.0.2 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-paste-script (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Randy Barlow
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On: 1214736
Blocks: PYTHON3
  Show dependency treegraph
 
Reported: 2015-05-25 21:07 EDT by Upstream Release Monitoring
Modified: 2017-01-03 23:25 EST (History)
4 users (show)

See Also:
Fixed In Version: python-paste-script-2.0.2-1.fc26
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-03 23:25:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[patch] Update to 2.0 (#1224837) (1.11 KB, text/x-diff)
2015-05-25 21:08 EDT, Upstream Release Monitoring
no flags Details
[patch] Update to 2.0.1 (#1224837) (1.12 KB, text/x-diff)
2015-05-26 09:09 EDT, Upstream Release Monitoring
no flags Details
[patch] Update to 2.0.2 (#1224837) (1.12 KB, text/x-diff)
2015-05-27 21:13 EDT, Upstream Release Monitoring
no flags Details

  None (edit)
Description Upstream Release Monitoring 2015-05-25 21:07:46 EDT
Latest upstream release: 2.0
Current version/release in rawhide: 1.7.5-8.fc21
URL: https://pypi.python.org/pypi/PasteScript

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-05-25 21:08:00 EDT
Created attachment 1029718 [details]
[patch] Update to 2.0 (#1224837)
Comment 2 Upstream Release Monitoring 2015-05-25 21:11:44 EDT
Scratch build failed http://koji.fedoraproject.org/koji/taskinfo?taskID=9848966
Comment 3 Upstream Release Monitoring 2015-05-26 09:09:32 EDT
Latest upstream release: 2.0.1
Current version/release in rawhide: 1.7.5-8.fc21
URL: https://pypi.python.org/pypi/PasteScript

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 4 Upstream Release Monitoring 2015-05-26 09:09:44 EDT
Created attachment 1029934 [details]
[patch] Update to 2.0.1 (#1224837)
Comment 5 Upstream Release Monitoring 2015-05-26 09:13:52 EDT
Scratch build failed http://koji.fedoraproject.org/koji/taskinfo?taskID=9851507
Comment 6 Upstream Release Monitoring 2015-05-27 21:13:33 EDT
Latest upstream release: 2.0.2
Current version/release in rawhide: 1.7.5-8.fc21
URL: https://pypi.python.org/pypi/PasteScript

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 7 Upstream Release Monitoring 2015-05-27 21:13:44 EDT
Created attachment 1030883 [details]
[patch] Update to 2.0.2 (#1224837)
Comment 8 Upstream Release Monitoring 2015-05-27 21:15:42 EDT
Scratch build failed http://koji.fedoraproject.org/koji/taskinfo?taskID=9859279
Comment 9 Dan Callaghan 2015-06-11 20:01:16 EDT
The project changelog hasn't been updated since 1.7.5 but looking at the commit history it seems the 2.0.x series is just about adding Python 3 support. However there doesn't seem to be any strong claims about maintaining compatibility, so it looks like this should go to rawhide only.
Comment 10 Dan Callaghan 2015-06-11 20:11:13 EDT
Also I assume this will depend on Paste 2.0.x also.
Comment 11 Tomas Orsava 2016-05-10 11:31:08 EDT
Upstream, this software supports Python 3. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's OK to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 24 as well.


If you need more instructions, a guide for porting Python-based RPMs is
available at [2].
If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
[2] http://python-rpm-porting.readthedocs.io/
Comment 12 Dominika Krejčí 2016-06-28 06:34:14 EDT
Hi Luke, how is it going? Do you need some help?
Comment 13 Upstream Release Monitoring 2017-01-03 23:22:39 EST
bowlofeggs's python-paste-script-2.0.2-1.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=831059
Comment 14 Randy Barlow 2017-01-03 23:25:08 EST
Due to some of the concerns raised about backwards compatibility, I decided to play it safe and only release this version in Rawhide. I ended up majorly refactoring the spec file in the process, but as a result we now also have python2- and python3- versions of this package (with properly named executables for each). I am inclined to let Fedora 24/25 stay as they are for now, without having a python3- version.

Note You need to log in before you can comment on or make changes to this bug.