Bug 1224883 - ovirt-engine fails to start to jboss eap 6.3 bug with jdk 1.8.0.45
Summary: ovirt-engine fails to start to jboss eap 6.3 bug with jdk 1.8.0.45
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-appliance
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ovirt-3.6.0-rc3
: 3.6.0
Assignee: Fabian Deutsch
QA Contact: Gonza
URL:
Whiteboard:
Depends On: 1080026
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-26 06:41 UTC by Roy Golan
Modified: 2016-03-09 21:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 21:43:55 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0385 normal SHIPPED_LIVE rhevm-appliance bug fix and enhancement update 2016-03-10 02:43:23 UTC

Description Roy Golan 2015-05-26 06:41:18 UTC
Description of problem:

engine fails to start with error

org.apache.jasper.JasperException: JBWEB004062: Unable to compile class for JSP: 

JBWEB004061: An error occurred at line: 26 in the generated java file
The type java.util.Map$Entry cannot be resolved. It is indirectly referenced from required .class files

JBWEB004211: Stacktrace:
	org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:85)
	org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:69)
	org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:451)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:361)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:339)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:326)
	org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:606)



jboss eap 6.3 has a known Bug 1080026 - root cause is a package name ecj



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. start ovirt engine
2. go to welcome page https://localhost/ovirt-engine
3. blow with errors above mentioned

Comment 1 Fabian Deutsch 2015-05-26 11:15:26 UTC
Let's hope that this bug is fixed with a fresh RHEV-M Appliance build.
We'll need to rebuild for 3.4.5 anyway and we can address this bug there.

Comment 3 Fabian Deutsch 2015-05-27 12:33:45 UTC
Roy, please give the complete appliance name of the appliance you used.

Comment 4 Roy Golan 2015-05-28 05:31:12 UTC
 /usr/share/ovirt-engine-appliance/rhevm-appliance-20150513.0-1.ova

Comment 5 Fabian Deutsch 2015-05-28 06:03:39 UTC
Thanks. We actually had this bug in our 3.5 and 3.6 builds.

This has been fixed in the 3.5 and 3.6 tags since yesterday.
This bug can then be validated once a new RHEV-M Appliance build is ready.

Comment 7 Gonza 2015-11-24 11:05:22 UTC
Verified with:
rhevm-appliance-20151119.0-1
rhevm-appliance-20151115.0-1

Both rhevm-appliance for 3.5 and 3.6 complete setup successfully and webadmin is accessible with no errors.

Comment 9 errata-xmlrpc 2016-03-09 21:43:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0385


Note You need to log in before you can comment on or make changes to this bug.