Bug 1224902 - [New] - cannot create snapshot while geo-replication session is running on the volume.
Summary: [New] - cannot create snapshot while geo-replication session is running on th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: RHGS 3.1.0
Assignee: Shubhendu Tripathi
QA Contact: Stanislav Graf
URL:
Whiteboard:
Depends On: 1230646 1231789 1233056
Blocks: 1202842 1224288
TreeView+ depends on / blocked
 
Reported: 2015-05-26 07:31 UTC by RamaKasturi
Modified: 2015-07-29 05:30 UTC (History)
9 users (show)

Fixed In Version: rhsc-3.1.0-61
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-29 05:30:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot for snapshot creation (231.97 KB, image/png)
2015-07-04 09:02 UTC, Arthy Loganathan
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1494 0 normal SHIPPED_LIVE Red Hat Gluster Storage Console 3.1 Enhancement and bug fixes 2015-07-29 09:24:02 UTC
oVirt gerrit 41491 0 master MERGED gluster: Corrected geo-rep case of volume snapshot creation Never
oVirt gerrit 42750 0 ovirt-engine-3.5-gluster MERGED gluster: Corrected geo-rep case of volume snapshot creation Never

Description RamaKasturi 2015-05-26 07:31:28 UTC
Description of problem:
creating snapshot on a volume which has geo rep session running fails with error while executing action create gluster volume snapshot: command execution failed. snapshot command failed.

Version-Release number of selected component (if applicable):
rhsc-3.1.0-0.0.scratch.master.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a geo replication session for a volume from the UI and start it.
2. Now click on snapshot->New
3. give some snap name and say "OK"

Actual results:
snapshot creation fails.

Expected results:
snapshot creation should succeed.

Additional info:

Comment 2 RamaKasturi 2015-05-26 07:38:31 UTC
Engine and vdsm logs can be found in the link below.

http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/rhsc/1224902/

Comment 6 Arthy Loganathan 2015-07-04 09:02:29 UTC
Created attachment 1045990 [details]
screenshot for snapshot creation

Comment 7 Arthy Loganathan 2015-07-04 09:04:58 UTC
Unable to create snapshot for volume when geo rep session is running in build rhsc-3.1.0-0.62.el6.noarch.(screenshot attached). Hence moving this bug to assigned state.

Comment 8 Shubhendu Tripathi 2015-07-06 04:06:35 UTC
The error is from Gluster itself. The geo-replication session pause is failing.
Kotresh, can you please check this out?

Comment 10 Arthy Loganathan 2015-07-06 10:13:02 UTC
Verified the fix in build,
rhsc-3.1.0-0.62.el6.noarch

Separate bug 1240196 has been raised for the issue mentioned in comment 7 and 8.
Snapshot creation works fine when all the nodes in cluster is part of master volume.

Comment 11 Arthy Loganathan 2015-07-06 10:26:36 UTC
Refer comment 10

Comment 12 errata-xmlrpc 2015-07-29 05:30:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1494.html


Note You need to log in before you can comment on or make changes to this bug.