Bug 1225016 - Overcloud: Download of glance image fails because of wrong glance_store option.
Summary: Overcloud: Download of glance image fails because of wrong glance_store option.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: Director
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ga
: Director
Assignee: Emilien Macchi
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-26 12:16 UTC by Leonid Natapov
Modified: 2015-08-05 13:51 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-25.el7ost
Doc Type: Bug Fix
Doc Text:
On the Overcloud, the glance_store section in /etc/glance/glance-api.conf file sets stores=glance.store.filesystem.Store. This caused problems with image uploads due to the different store types. This fix modifies glance configuration to use glance.store.http.Store for the stores parameter and to include a backend for the store type to use.
Clone Of:
Environment:
Last Closed: 2015-08-05 13:51:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 194762 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Leonid Natapov 2015-05-26 12:16:18 UTC
openstack-tripleo-heat-templates-0.8.6-dev15.el7.centos.noarch
openstack-tripleo-0.0.6-dev1717.el7.centos.noarch
openstack-tripleo-puppet-elements-0.0.1-dev63.el7.centos.noarch
tripleo-common-0.0.1-dev3.el7.centos.noarch
openstack-tripleo-image-elements-0.9.5-post1.el7.centos.noarch

While trying to download a glance image  getting the following error:

400 Bad Request: External sources are not supported: 'http://jenkins-storm.qa.lab.tlv.redhat.com/final.qcow2' (HTTP 400)

Quick investigation showed that glance_store option in glance-api.conf file enables stores=glance.store.filesystem.Store.


The fix should be to adds the glance.store.http.Store to the known stores. 

How reproducible:

100%

Steps to Reproduce:
1.Try to download image using http.
2.
3.

Actual results:
Image fails to download.

Expected results:
Image can be successfully downloaded. 


We experienced the same issue in staypuft. Pls,look at https://bugzilla.redhat.com/show_bug.cgi?id=1204647

Comment 4 Emilien Macchi 2015-06-23 17:46:37 UTC
Submitted upstream: https://review.openstack.org/194762

Comment 7 Ofer Blaut 2015-07-19 11:06:54 UTC
stack@puma33 ~]$  glance image-create --name cirros --disk-format qcow2 --container-format bare --is-public 1 --copy-from https://launchpad.net/cirros/trunk/0.3.0/+download/cirros-0.3.0-x86_64-disk.img
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | None                                 |
| container_format | bare                                 |
| created_at       | 2015-07-19T11:03:22.000000           |
| deleted          | False                                |
| deleted_at       | None                                 |
| disk_format      | qcow2                                |
| id               | 25724471-4298-4dd6-a86d-9dbfffc31c05 |
| is_public        | True                                 |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | cirros                               |
| owner            | 14cfb7c1578d41dca52d8f88eb104471     |
| protected        | False                                |
| size             | 9761280                              |
| status           | queued                               |
| updated_at       | 2015-07-19T11:03:22.000000           |
| virtual_size     | None                                 |
+------------------+--------------------------------------+
[stack@puma33 ~]$ 
[stack@puma33 ~]$ 
[stack@puma33 ~]$ 
[stack@puma33 ~]$ 
[stack@puma33 ~]$ glance image-list
+--------------------------------------+--------+-------------+------------------+---------+--------+
| ID                                   | Name   | Disk Format | Container Format | Size    | Status |
+--------------------------------------+--------+-------------+------------------+---------+--------+
| 25724471-4298-4dd6-a86d-9dbfffc31c05 | cirros | qcow2       | bare             | 9761280 | active |
+--------------------------------------+--------+-------------+------------------+---------+--------+
[stack@puma33 ~]$ 
[stack@puma33 ~]$ 
[stack@puma33 ~]$ 
[stack@puma33 ~]$ rpm -qa | grep heat-te
openstack-heat-templates-0-0.6.20150605git.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-44.el7ost.noarch

Comment 9 errata-xmlrpc 2015-08-05 13:51:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.