Bug 1225024 - [RHEL-6.7-Snapshot-1] cpuspeed reports error while booting into OS.
Summary: [RHEL-6.7-Snapshot-1] cpuspeed reports error while booting into OS.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cpuspeed
Version: 6.7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Petr Šabata
QA Contact: Erik Hamera
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-26 12:29 UTC by Sujith
Modified: 2015-07-31 12:59 UTC (History)
7 users (show)

Fixed In Version: cpuspeed-1.5-21.el6
Doc Type: Bug Fix
Doc Text:
Cause A change in the kernel introducing the intel_pstate driver, incompatible with how scaling was managed until 6.7, was brought in. Consequence The cpuspeed service printed, albeit only cosmetic, errors during system boot and shutdown. Fix Since the intel_pstate driver handles performance scaling on its own, the service is now effectively disabled on platforms using it. Result The service initscript was altered so it bails out on platforms using the intel_pstate driver. Users may also safely disable it entirely.
Clone Of:
Environment:
Last Closed: 2015-07-22 07:46:16 UTC


Attachments (Terms of Use)
boot.log (10.70 KB, application/octet-stream)
2015-05-26 12:29 UTC, Sujith
no flags Details
cpuinfo (112.46 KB, text/plain)
2015-05-26 12:30 UTC, Sujith
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1440 normal SHIPPED_LIVE cpuspeed bug fix update 2015-07-20 18:05:48 UTC

Description Sujith 2015-05-26 12:29:20 UTC
Created attachment 1029918 [details]
boot.log

Description of problem:
After the installation of RHEL-6.7-Snapshot-1, during booting into any rc mode list of error messages "/etc/rc5.d/S13cpuspeed: line91: echo: write error: Invalid argument" are seen.

Version-Release number of selected component (if applicable):
cpuspeed-1.5-20.el6_4

How reproducible:
Always while booting into rc modes like rc5, rc4, rc3, rc2 and rc1.

Steps to Reproduce:
1.Install RHEL-6.7-Snapshot-1
2.Boot into the installed OS. (Generally in run level 5)
3.Check the boot.log messages for error messages for current run level.

Actual results:
Error messages by cpuspeed are seen.
"/etc/rc5.d/S13cpuspeed: line91: echo: write error: Invalid argument"
Starting cpuspeed [failed]

Expected results:
No Error messages. cpuspeed should work properly.

Additional info:
#cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_available_governors
performance powersave

#cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
powersave


Seems like /etc/rc5.d/S13cpuspeed is trying to insert values like "userspace" or "ondemand" or "conservative" and is failing because its not supported by the system.

Similar issue was listed in https://access.redhat.com/solutions/328853

Comment 1 Sujith 2015-05-26 12:30:10 UTC
Created attachment 1029919 [details]
cpuinfo

Comment 2 Petr Šabata 2015-05-26 12:35:34 UTC
Thank you for the report.  This is a known issue affecting Intel platforms caused by changes in the kernel.

This is of a purely cosmetic nature and you can safely disable the cpuspeed service as scaling and performance management is now done by the kernel driver directly.

Comment 3 Sujith 2015-05-26 13:20:19 UTC
In that case, can you please disable this service from init.d, just to prevent any confusion from user-end?

Comment 4 Petr Šabata 2015-05-26 13:34:41 UTC
(In reply to Sujith from comment #3)
> In that case, can you please disable this service from init.d, just to
> prevent any confusion from user-end?

Yes, something along those lines is the planned fix for this problem.

Comment 5 Petr Šabata 2015-05-29 12:08:57 UTC
Fixed in cpuspeed-1.5-21.el6.

Comment 7 errata-xmlrpc 2015-07-22 07:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1440.html


Note You need to log in before you can comment on or make changes to this bug.