Bug 122503 - helvetica, times ... not in fonts.dir
helvetica, times ... not in fonts.dir
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: urw-fonts (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-05 05:14 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 12:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-05-05 05:14:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.4.1)
Gecko/20031114

Description of problem:
rpm -qi urw-fonts:

...
 The fonts.dir file font names match the original Adobe names of the fonts
(e.g., Times, Helvetica, etc.).
...

X11-Core-Fontsystem using xfs:

fonts.dir not contains "helvetica" e.g.
fonts.dir is build with "mkfontdir", fonts.scale with "mkfontscale"
using the fontfiles (s050000l.afm ...). Fontfiles not contents this names.

Formerly fonts.dir and fonts.scale became distributed by rpm.

Xft:

fc-cache produced fonts.cache-1 without "helvetica" ...


Note:
Fontnames "Times", "Helvetica" and so on are very important for users!
Many programs this awaiting!
We have installed Fedora (formerly RedHat) on very many computers.
Users exasperate in relations to modifications in this regard (not
only urw-fonts). The are not informatics and attach importance to
stable work. To defend against W... is very hard ... 

Version-Release number of selected component (if applicable):
urw-fonts-2.1-5.1

How reproducible:
Always

Steps to Reproduce:
1. OpenOffice and old documents (Helvetica 
2. mathematica (not OpenSource)
3. ...
    

Additional info:
Comment 1 John Thacker 2006-04-21 12:23:09 EDT
This can't actually be fixed, sorry.  They aren't "real" versions of Times and
Helvetica, and can't be named as such.

For example, Helvetica is a trademark of Heidelberger Druckmaschinen AG and
exclusively licensed through Linotype GmbH.  Nimbus Sans strongly resembles it,
and it based on it, but cannot share the same name.  Xft's aliasing means that
it works pretty closely, though.  Xft will match requests for Times and
Helvetica with the near matches, "Nimbus Roman No9 L" and "Nimbus Sans."
Comment 2 Mark Alford 2007-07-03 16:20:55 EDT
Comment #1 states "Xft will match requests for Times and
Helvetica with the near matches, "Nimbus Roman No9 L" and "Nimbus Sans."
but this doesn't seem to be true. The command
> xload -fn '-*-helvetica-bold-r-normal--21-*-*-*-*-*-ISO8859-*'
yields the message:
  Warning: Cannot convert string
"-*-helvetica-bold-r-normal--21-*-*-*-*-*-ISO8859-*" to type FontStruct

This behavior is observed under Fedora 7 with urw-fonts-2.3-6.1.1.
Comment 3 Jens Petersen 2007-10-07 19:47:59 EDT
(In reply to comment #2)
> The command
> > xload -fn '-*-helvetica-bold-r-normal--21-*-*-*-*-*-ISO8859-*'
> yields the message:
>   Warning: Cannot convert string
> "-*-helvetica-bold-r-normal--21-*-*-*-*-*-ISO8859-*" to type FontStruct

That is not using Xft, but X core fonts.  You can use xlsfonts to list
the core fonts available.
Comment 4 Jens Petersen 2007-10-07 19:55:38 EDT
*** Bug 245961 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.