Bug 1225077 - Fix regression test spurious failures
Summary: Fix regression test spurious failures
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
: 1217879 (view as bug list)
Depends On: 1163543 1219028
Blocks: glusterfs-3.7.7
TreeView+ depends on / blocked
 
Reported: 2015-05-26 14:10 UTC by Niels de Vos
Modified: 2016-03-10 09:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-10 09:22:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2015-05-26 14:10:53 UTC
Tracker for all the spurious tests that need a backport from the master branch to release-3.7.

Comment 1 Anand Avati 2015-05-27 03:38:57 UTC
REVIEW: http://review.gluster.org/10923 (tests: arbiter.t fix) posted (#1) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)

Comment 2 Anand Avati 2015-05-27 04:00:56 UTC
REVIEW: http://review.gluster.org/10922 (tests: Fix entry-self-heal.t) posted (#2) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)

Comment 3 Anand Avati 2015-05-27 04:15:44 UTC
REVIEW: http://review.gluster.org/10924 (tests: data-self-heal.t fixes) posted (#1) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)

Comment 4 Anand Avati 2015-05-27 07:52:15 UTC
COMMIT: http://review.gluster.org/10923 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit 7a001525850fc60d24be019e4fba726d3c33ee5e
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Wed May 27 08:45:52 2015 +0530

    tests: arbiter.t fix
    
    Backport of http://review.gluster.org/10833
    
    Wait for AFR's children to be up in glustershd process before attempting heal.
    
    Also, grep (version 2.21) is detecting statedump files as binary, causing tests
    to succeed incorrectly. Hence adding the -a switch to force it to treat it as a
    text file. Thanks to Vijay Bellur for identifying the issue
    (http://lists.gnu.org/archive/html/bug-grep/2015-05/msg00000.html) and the
    workaround.
    
    Change-Id: Ie3d9591ffaf44baa0cd8c2baa327aed24378e3df
    BUG: 1225077
    BUG:
    Reviewed-on: http://review.gluster.org/10833
    Tested-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    (cherry picked from commit b51ee5f8d1f80d66effffc06c1e49099c04014a4)
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/10923
    Tested-by: NetBSD Build System
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 5 Anand Avati 2015-05-27 10:16:37 UTC
REVIEW: http://review.gluster.org/10939 (tests: Disable flush-behind) posted (#1) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)

Comment 6 Anand Avati 2015-05-27 11:34:01 UTC
REVIEW: http://review.gluster.org/10941 (tests: Await for graph switch before testing open fop count) posted (#1) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)

Comment 7 Anand Avati 2015-05-27 16:11:17 UTC
REVIEW: http://review.gluster.org/10939 (tests: Disable flush-behind) posted (#2) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)

Comment 8 Anand Avati 2015-05-27 19:40:08 UTC
REVIEW: http://review.gluster.org/10941 (tests: Await for graph switch before testing open fop count) posted (#2) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)

Comment 9 Anand Avati 2015-05-28 06:47:33 UTC
COMMIT: http://review.gluster.org/10939 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit de04160253515dc55389af2f5750f856d150ee5e
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Wed May 27 15:26:46 2015 +0530

    tests: Disable flush-behind
    
    Change-Id: I2f56a6e8cc44da935ce3b1f76142e960d5eb698f
    BUG: 1225077
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/10939
    Tested-by: NetBSD Build System

Comment 10 Anand Avati 2015-05-28 09:34:34 UTC
COMMIT: http://review.gluster.org/10941 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit 2b8fdde926532014f19d850b1321a4c7046dc001
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Wed May 27 16:59:19 2015 +0530

    tests: Await for graph switch before testing open fop count
    
    In performance/open-behind.t, a test for open fop reaching the brick is done by
    switching off open-behind and performing a read operation. If the read operation
    is performed before a graph switch, the read happens on the old graph and hence
    open does not get accounted in the brick.
    
    To overcome this EXPECT_WITHIN 10 seconds has now been added to ensure that a
    graph switch has happened. The read operation happens subsequently after the
    graph switch.
    
    Cleaned up a "No volumes present" message from stderr while doing this.
    
    Change-Id: I05f7cbfd1ce51782f5ab778468a980d3732509a2
    BUG: 1225077
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/10941
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 11 Anand Avati 2015-05-29 07:00:54 UTC
REVIEW: http://review.gluster.org/10990 (tests: Remove tests from bad tests) posted (#1) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)

Comment 12 Anand Avati 2015-05-29 07:26:26 UTC
REVIEW: http://review.gluster.org/10992 (tier/tier.t: Fixing tier.t crash in regression runs) posted (#1) for review on release-3.7 by Joseph Fernandes (josferna@redhat.com)

Comment 13 Anand Avati 2015-05-30 06:21:20 UTC
REVIEW: http://review.gluster.org/10992 (tier/tier.t: Fixing tier.t crash in regression runs) posted (#2) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)

Comment 14 Anand Avati 2015-05-30 14:17:45 UTC
REVIEW: http://review.gluster.org/10992 (tier/tier.t: Fixing tier.t crash in regression runs) posted (#3) for review on release-3.7 by Vijay Bellur (vbellur@redhat.com)

Comment 15 Anand Avati 2015-05-30 15:07:38 UTC
COMMIT: http://review.gluster.org/10992 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit 3b4980919bf23b952fa5155bc8f9d59613cbafb7
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Thu May 21 11:17:59 2015 +0530

    tier/tier.t: Fixing tier.t crash in regression runs
    
    1) If the database file exists
       a. Dont try re-creating the db schema
       b. Dont try re-configuring the db.
    
    2) Dont assert in fini_db () when connection is NULL
    
    >> Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    >> Reviewed-on: http://review.gluster.org/10870
    >> Tested-by: NetBSD Build System
    >> Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    >> Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    >>Change-Id: Idd2833f55caaa6b3a77d935d877d6c4d2994da6a
    
    Change-Id: Ia2e044fce4e41bccc8fdada1cb21f240fdbd55df
    BUG: 1225077
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/10992
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Vijay Bellur <vbellur@redhat.com>

Comment 16 Niels de Vos 2015-06-02 08:20:20 UTC
The required changes to fix this bug have not made it into glusterfs-3.7.1. This bug is now getting tracked for glusterfs-3.7.2.

Comment 17 Niels de Vos 2015-06-20 10:08:35 UTC
Unfortunately glusterfs-3.7.2 did not contain a code change that was associated with this bug report. This bug is now proposed to be a blocker for glusterfs-3.7.3.

Comment 18 Kaushal 2015-07-30 13:17:43 UTC
This bug could not be fixed in time for glusterfs-3.7.3. This is now being tracked for being fixed in glusterfs-3.7.4.

Comment 19 Kaushal 2015-10-28 12:28:31 UTC
This bug could not be fixed in time for glusterfs-3.7.4 or glusterfs-3.7.5. This is now being tracked for being fixed in glusterfs-3.7.6.

Comment 20 Raghavendra Talur 2015-11-08 20:26:36 UTC
This bug could not be fixed in time for glusterfs-3.7.6.
This is now being tracked for being fixed in glusterfs-3.7.7.

Comment 21 Vijay Bellur 2016-02-14 04:24:35 UTC
*** Bug 1217879 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.