Bug 1225186 - binutils ar adds files to libraries with a date of "Jan 1 01:00 1970"
Summary: binutils ar adds files to libraries with a date of "Jan 1 01:00 1970"
Keywords:
Status: CLOSED DUPLICATE of bug 1195883
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils
Version: 22
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Nick Clifton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-26 18:58 UTC by Paul
Modified: 2015-05-26 19:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-26 19:08:19 UTC


Attachments (Terms of Use)

Description Paul 2015-05-26 18:58:46 UTC
I upgraded to Fedora 22 an hour ago and saw this bug with "ar" which happens everytime

Steps to Reproduce:

echo "void func(){}" > s.c
rm -f lib.a s.o
/usr/bin/gcc -c s.c
/usr/bin/ar rv lib.a s.o
/usr/bin/ar tv lib.a
/usr/bin/ls -l

Actual results:
/usr/bin/ar: creating lib.a
a - s.o
rw-r--r-- 0/0   1224 Jan  1 01:00 1970 s.o
total 16
-rw-r-----. 1 pas pas 1366 May 26 19:48 lib.a
-rw-r-----. 1 pas pas   14 May 26 19:48 s.c
-rw-r-----. 1 pas pas 1224 May 26 19:48 s.o

Expected results:
I'd expect to see the s.o file in lib.a have a time of 19:48

Additional info:
Using binutils-2.25-5.fc22.x86_64

I've put this with a priority of High, if it's my mistake then ignore me, but if it's a real bug it should be urgent.

Workaround
I'm actually using Makefiles so after I build a libaray, I'm using "make -t" which touches all the targets in the library with the current time

Comment 1 Paul 2015-05-26 19:08:19 UTC
This appears to be a duplicate of bug 1195883, bye bye everybodies compilation enviroments.

*** This bug has been marked as a duplicate of bug 1195883 ***


Note You need to log in before you can comment on or make changes to this bug.