Bug 122519 - [PATCH] /usr/lib/libgcrypt.so.* is not owned by package
Summary: [PATCH] /usr/lib/libgcrypt.so.* is not owned by package
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: libgcrypt   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-05 13:42 UTC by Michael Schwendt
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-05 21:09:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for spec file (774 bytes, patch)
2004-05-05 13:43 UTC, Michael Schwendt
no flags Details | Diff

Description Michael Schwendt 2004-05-05 13:42:34 UTC
$ rpm -qf /usr/lib/libgcrypt.so.11
file /usr/lib/libgcrypt.so.11 is not owned by any package

$ rpm -q libgcrypt
libgcrypt-1.1.94-1

Also true for libgcrypt-1.2.0-1 in rawhide. Trivial patch attached.

Comment 1 Michael Schwendt 2004-05-05 13:43:21 UTC
Created attachment 99989 [details]
patch for spec file

Comment 2 Nalin Dahyabhai 2004-05-05 21:09:16 UTC
The link is created and managed by ldconfig.  I'm inclined to let
ldconfig continue to handle it, so marking wontfix.

Comment 3 Cristian Gafton 2004-05-05 21:36:50 UTC
teher could be a case made for having those files as %ghost...

Comment 4 Michael Schwendt 2004-05-05 22:17:23 UTC
* Nalin, I do respect your decision, but it is a bad one, since not
including the link creates an inconsistency between what

  $ rpm -q --provides libgcrypt
  libgcrypt.so.11  

reports and what is included in the package actually. In particular,
this makes it difficult to check for damaged packages with "rpm -V"
(as what applications link against is not included in the package!)

* %ghost'ing the link would work, too, but would require more effort
at the spec file level.

* Btw, "rpm -qf /usr/lib/*.so.?" reveals that indeed the majority of
packages include these links.



Note You need to log in before you can comment on or make changes to this bug.