Bug 1225254 - TypeError: CGI is not a module
Summary: TypeError: CGI is not a module
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hub
Version: 22
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ralph Bean
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1227005 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-27 00:52 UTC by Evan Nemerson
Modified: 2016-03-17 19:47 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-03-17 19:47:54 UTC


Attachments (Terms of Use)

Description Evan Nemerson 2015-05-27 00:52:21 UTC
On F22, when I try to run hub (any command will trigger it, even `hub --help`), I get:

TypeError: CGI is not a module
   (root) at /usr/share/gems/gems/hub-1.12.4/lib/hub/speedy_stdlib.rb:9
  require at org/jruby/RubyKernel.java:1071
   (root) at /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:1
  require at /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:54
  require at org/jruby/RubyKernel.java:1071
   (root) at /usr/share/gems/gems/hub-1.12.4/lib/hub.rb:2
   (root) at /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:1
     load at org/jruby/RubyKernel.java:1087
   (root) at /usr/bin/hub:23

Comment 1 Fedora Update System 2015-05-27 20:06:52 UTC
hub-1.12.4-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hub-1.12.4-2.fc22

Comment 2 Fedora Update System 2015-05-27 20:07:06 UTC
hub-1.12.4-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/hub-1.12.4-2.fc21

Comment 3 Fedora Update System 2015-05-27 20:07:18 UTC
hub-1.12.4-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hub-1.12.4-2.fc20

Comment 4 lnie 2015-05-29 08:26:13 UTC
hub-1.12.4-2.fc22 works

Comment 5 Ralph Bean 2015-06-01 18:29:21 UTC
*** Bug 1227005 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2015-06-09 15:06:14 UTC
hub-1.12.4-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2015-06-09 15:17:15 UTC
hub-1.12.4-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2015-06-09 15:18:02 UTC
hub-1.12.4-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.