Bug 1225277 - python(abi) = 3.3 is needed by (installed)
Summary: python(abi) = 3.3 is needed by (installed)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 21
Hardware: x86_64 Linux
unspecified
unspecified
Target Milestone: ---
Assignee: packaging-team-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-27 02:30 UTC by Fco Vzqz
Modified: 2016-02-27 00:32 UTC (History)
8 users (show)

Fixed In Version: dnf-1.0.1-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-28 11:21:55 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fco Vzqz 2015-05-27 02:30:26 UTC
Description of problem:
when triying to upgrade to fedora 22  with DNF i get the folling error:


Version-Release number of selected component (if applicable):
fedora 21

How reproducible:
everytime I type dnf upgrade, then the transaction check fails

Steps to Reproduce:
1. su
2. dnf upgrade
3. type y  when promptted 
Transaction Summary
===================================================================================================
Install   44 Packages
Upgrade  763 Packages
Remove     4 Packages

Total size: 1.6 G
Is this ok [y/N]: 


Actual results:

Running transaction check
Error: transaction check vs depsolve:
python(abi) = 3.3 is needed by (installed) python3-ecdsa-0.11-6.1.noarch
python(abi) = 3.3 is needed by (installed) python3-netifaces-0.10.4-7.1.x86_64
python(abi) = 3.3 is needed by (installed) python3-jsonschema-2.3.0-23.2.noarch
python(abi) = 3.3 is needed by (installed) python3-certifi-14.05.14-2.1.noarch
python(abi) = 3.3 is needed by (installed) python3-apache-libcloud-0.16.0-9.1.noarch
python(abi) = 3.3 is needed by (installed) python3-paramiko-1.15.1-5.1.noarch
To diagnose the problem, try running: 'rpm -Va --nofiles --nodigest'.
To fix inconsistent RPMDB, try running: 'rpm --rebuilddb'.
If the above doesn't help please report this error at 'https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&component=dnf'.

Comment 1 Honza Silhan 2015-05-28 11:21:55 UTC
I am sorry but I can't help you with the corrupted RPMDB. This is not a DNF bug and we cannot figure out what was the cause so I have erased the bug report message in the upstream.

Comment 2 Jan Zeleny 2015-05-28 12:05:09 UTC
For the record, the easiest solution that will unblock you is to use rpm to remove the packages that need python(abi) = 3.3, i.e. python3-ecdsa-0.11-6.1.noarch, and others in that list. All subsequent operations should work after that cleanup.

Comment 3 Fedora Update System 2015-06-12 09:05:40 UTC
dnf-1.0.1-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-1.0.1-2.fc22

Comment 4 Fedora Update System 2015-06-21 00:16:22 UTC
dnf-1.0.1-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fco Vzqz 2016-02-27 00:32:54 UTC
(In reply to Jan Zeleny from comment #2)
> For the record, the easiest solution that will unblock you is to use rpm to
> remove the packages that need python(abi) = 3.3, i.e.
> python3-ecdsa-0.11-6.1.noarch, and others in that list. All subsequent
> operations should work after that cleanup.

Many thanks! I will try it out.
thanks!


Note You need to log in before you can comment on or make changes to this bug.