Bug 122529 - rh-postgresql-test package has broken Makefiles
rh-postgresql-test package has broken Makefiles
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rh-postgresql (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-05 11:17 EDT by David Lawrence
Modified: 2013-07-02 23:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-05 22:36:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2004-05-05 11:17:00 EDT
Description of problem:
The gmake check functionality in rh-postgresql-test does not work due
to improper paths in the makefiles. This is the error I get when I go
to the regress test directory installed by the test package.

.qa.[root@isqa3 regress]# gmake check
GNUmakefile:16: ../../../src/Makefile.global: No such file or directory
gmake: *** No rule to make target `../../../src/Makefile.global'.  Stop.

After some more playing I was able to get the gmake checks to work by
doing the following with the actual rh-postgresql source rpm after
performing a rpmbuild -bc:

rpm -ivh rh-postgresql-7.3.6-1.src.rpm
rpmbuild -bc rh-postgresql.spec
cd ../BUILD/postgresql-7.3.6/src/test
chown -R postgres.postgres regress/*
cd regress
su - postgres
gmake check

Version-Release number of selected component (if applicable):
rh-postgresql-7.3.6-1
Comment 1 Tom Lane 2004-05-05 14:23:54 EDT
I think the real problem here is that you are not performing the
regression tests in the intended way.  The BUILD tree cannot be used
for this because it is typically root-owned.  The recommended way to
run the regression tests with an RPM build is to install and start the
postmaster, then use the installed regression test tree.  See the
REGRESSION TESTING notes in the README.rpm-dist file.
Comment 2 Tom Lane 2004-05-05 22:36:52 EDT
Closing as pilot error.  (It *would* be nice if the standard PG
regression test procedure worked for the RPMs, but I think it'll take
upstream changes to make that workable at all.)

Note You need to log in before you can comment on or make changes to this bug.