Bug 1225358 - Compiz crash if animation plugin is used
Summary: Compiz crash if animation plugin is used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz-plugins-extra
Version: 22
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-27 08:12 UTC by Rabin
Modified: 2015-06-01 17:01 UTC (History)
3 users (show)

Fixed In Version: compiz-plugins-extra-0.8.8-15.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-01 17:01:03 UTC
Type: Bug


Attachments (Terms of Use)
My compiz config file (2.32 KB, text/plain)
2015-05-27 09:31 UTC, Rabin
no flags Details

Description Rabin 2015-05-27 08:12:21 UTC
Description of problem:

Just upgraded to F22 from F21 using fedup.

When I enable the Animation plugin in compiz, 
and then close/minimize a windows, compiz will crash 

In my .xsession-errors file i get this message.

---
compiz: symbol lookup error: /usr/lib64/compiz/libanimationaddon.so: undefined symbol: animGetI
---

I looked up in Google and found this thread
- http://osdir.com/ml/scm-fedora-commits/2015-05/msg07394.html

seems like it's known problem and was fixed in release 14, 
but this the version I'm running right now, and still experiencing the problem.

# rpm -qa | grep compiz
compiz-0.8.8-29.fc22.x86_64
compiz-plugins-unsupported-0.8.8-13.fc22.x86_64
compiz-manager-0.6.0-21.fc22.noarch
compiz-plugins-main-0.8.8-14.fc22.x86_64
libcompizconfig-0.8.8-12.fc22.x86_64
compiz-mate-0.8.8-29.fc22.x86_64
compiz-plugins-extra-0.8.8-14.fc22.x86_64
compizconfig-python-0.8.4-12.fc22.x86_64

#rpm -q --changelog compiz-plugins-main-0.8.8-14.fc22.x86_64 | head
* Wed May 13 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1:0.8.8-14
- fix crash if animation plugin is used in f22

* Wed Mar 18 2015 Wolfgang Ulbrich <chat-to-me@raveit.de> - 1:0.8.8-13
- rebuild for f22



Version-Release number of selected component (if applicable):


How reproducible:

Every time.


Steps to Reproduce:
1. enable the animation plugin
2. close/minimze a windows --> compiz crash
3.

Actual results:
compiz crash

Expected results:
shiny animations :)

Additional info:

Comment 1 Matthias Saou 2015-05-27 08:36:09 UTC
I just performed a similar upgrade, and get a similar error, but on another one of the symbols :

compiz: symbol lookup error: /usr/lib64/compiz/libanimationaddon.so: undefined symbol: animGetF

I am also using compiz-plugins-main-0.8.8-14.fc22.x86_64 which includes compiz-plugins-main_animation-plugin-x11-wm.patch, but apparently doesn't solve the issue.

Comment 2 Wolfgang Ulbrich 2015-05-27 09:14:17 UTC
Can you please attach .config/compiz/compizconfig/default.ini ?
To see which animations ar used.
I use this one for animation plugin and don't get the issue with 0.8.8-14.fc22.x86_64.

[animation]
s0_glide1_away_angle = -90,000000
s0_zoom_from_center = 2
s0_minimize_effects = animation:Glide 1;

[animationaddon]
s0_beam_color = #7f7f7fff

I've enabled 'minimize' 'close' and 'rollup'.

Comment 3 Rabin 2015-05-27 09:31:30 UTC
Created attachment 1030433 [details]
My compiz config file

[animation]
s0_focus_effects = animation:Dodge;
s0_open_effects = animation:Random;animation:Fade;animation:Fade;
s0_close_effects = animationaddon:Burn;animation:Fade;animation:Fade;
s0_open_random_effects = animation:Fade;
s0_minimize_effects = animation:Random;
s0_minimize_random_effects = animationaddon:Glide 3;
s0_focus_durations = 128;

[animationaddon]
s0_fire_color = #6cbaffff

Comment 4 Matthias Saou 2015-05-27 15:42:07 UTC
And here is mine (my [animationaddon] section is empty) :

[animation]
s0_open_effects = animation:Random;animation:Fade;animation:Fade;
s0_close_effects = animation:Random;animation:Fade;animation:Fade;
s0_open_random_effects = animation:Dream;animation:Fade;animation:Glide 1;animation:Glide 2;animationaddon:Glide 3;animationaddon:Leaf Spread;animation:Sidekick;animation:Zoom;
s0_close_random_effects = animationaddon:Burn;animation:Dream;animation:Fade;animation:Glide 1;animation:Glide 2;animationaddon:Glide 3;animation:Sidekick;animation:Zoom;

Comment 5 Wolfgang Ulbrich 2015-05-27 17:18:25 UTC
Thanks.
Good news....more than 50% of the effects are working :)
Bad news....looks like that i have forgotten to fix the animation-addon plugin :-/
My list:
- failed:
Domino
explode
fold
airplane
glide3
Razr
Skewer
Teleporter
burn (baby burn)

- working:
fade in/out
fold bent
glide1
glide2
fold horizontal
leaf spread
sidekick
dream
vakuum
wave
magic lamp
zoom

So, please don't use the bad effects for the moment, i'm working to fix the animation-addon plugin, or disable the plugin.
Can you confirm?

Comment 6 Fedora Update System 2015-05-27 19:37:40 UTC
compiz-plugins-extra-0.8.8-15.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/compiz-plugins-extra-0.8.8-15.fc22

Comment 7 Rabin 2015-05-28 06:45:50 UTC
(In reply to Fedora Update System from comment #6)
> compiz-plugins-extra-0.8.8-15.fc22 has been submitted as an update for
> Fedora 22.
> https://admin.fedoraproject.org/updates/compiz-plugins-extra-0.8.8-15.fc22

Applying this version solved my problem. 
I re-enabled the plugins and no crashes this time when closing/minimizing windows.

Thank you very much :)

Comment 8 Fedora Update System 2015-05-30 15:35:44 UTC
Package compiz-plugins-extra-0.8.8-15.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing compiz-plugins-extra-0.8.8-15.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9046/compiz-plugins-extra-0.8.8-15.fc22
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-06-01 17:01:03 UTC
compiz-plugins-extra-0.8.8-15.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.