Bug 1225368 - [RFE] change VM monitoring to work on top of the new events mechanism
Summary: [RFE] change VM monitoring to work on top of the new events mechanism
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Piotr Kliczewski
QA Contact: Nisim Simsolo
URL:
Whiteboard:
: 1083070 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-27 08:30 UTC by Oved Ourfali
Modified: 2016-03-09 21:07 UTC (History)
14 users (show)

Fixed In Version: 3.6.0-4 alpha3
Doc Type: Enhancement
Doc Text:
The communication between the Red Hat Enterprise Virtualization Manager and hosts has been improved. An event-based mechanism now communicates changes in virtual machine statuses instead of polling. This significantly reduces latency and network bandwidth. The improvement is especially noticeable in large-scale environments where hosts or data centers are remote, or connected over a slow connection.
Clone Of:
Environment:
Last Closed: 2016-03-09 21:07:06 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC

Description Oved Ourfali 2015-05-27 08:30:56 UTC
In 3.6.0 we'll add a new events mechanism, that allows hosts to send events to the engine / to other hosts.

This feature is about changing the way we monitor for VM status, to be a combination of longer cycle monitoring, and event processing.

Comment 1 Michal Skrivanek 2015-06-03 08:00:30 UTC
*** Bug 1083070 has been marked as a duplicate of this bug. ***

Comment 4 Nisim Simsolo 2016-01-31 15:48:25 UTC
Verified: 
rhevm-3.6.3-0.1.el6
libvirt-client-1.2.17-13.el7_2.2.x86_64
sanlock-3.2.4-1.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.4.x86_64
vdsm-4.17.19-0.el7ev.noarch

See external tracker for Test plan executed.

Comment 6 errata-xmlrpc 2016-03-09 21:07:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.