Bug 1225477 - dns_nameservers for provisioning network set to 192.168.122.1 on baremetal env
Summary: dns_nameservers for provisioning network set to 192.168.122.1 on baremetal env
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-27 13:06 UTC by Marius Cornea
Modified: 2015-08-05 13:52 UTC (History)
6 users (show)

Fixed In Version: instack-undercloud-2.1.2-4.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:52:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
instack network settings (7.06 KB, text/plain)
2015-05-27 13:06 UTC, Marius Cornea
no flags Details


Links
System ID Priority Status Summary Last Updated
Gerrithub.io 236540 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Marius Cornea 2015-05-27 13:06:07 UTC
Created attachment 1030555 [details]
instack network settings

Description of problem:
The dns_nameservers for the provisioning network on the undercloud is set to 192.168.122.1 within a baremetal environment which breaks name resolution on overcloud nodes. 

Version-Release number of selected component (if applicable):
[stack@bldr16cc09 ~]$ rpm -qa | grep tripleo
openstack-tripleo-common-0.0.0.post4-1.el7ost.noarch
openstack-tripleo-heat-templates-0.8.4-2.el7ost.noarch
openstack-tripleo-image-elements-0.9.3-1.el7ost.noarch
openstack-tripleo-0.0.5-999.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.1.dev55-1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. install undercloud
2. neutron net-list
3. neutron subnet-show <subnet_id>

Actual results:
dns_nameservers set to 192.168.122.1

Expected results:
We should be able to provide DNS servers in the instack.answers file so overcloud nodes get a valid DNS server via DHCP on the provisioning network.

Additional info:
I'm attaching my instack.answers file and out of network related settings.

Comment 4 James Slagle 2015-06-23 13:56:31 UTC
merged: https://code.engineering.redhat.com/gerrit/#/c/51373/
built: instack-undercloud-2.1.2-3.el7ost

Comment 6 Marius Cornea 2015-06-29 09:07:11 UTC
Where should we set the dns server(s)? I don't see anything related in undercloud.conf but I might be missing something. Thanks

Comment 7 Giulio Fidente 2015-06-30 13:50:37 UTC
Marius, can you confirm your overcloud dns is not pointing to 192.168.122.1 anymore though? (but to the neutron managed dnsmasq running in the undercloud)

Comment 8 Marius Cornea 2015-06-30 14:46:51 UTC
Confirmed, overcloud resolv.conf contains the ip address set on the dhcp namespace on the undercloud.

Comment 9 James Slagle 2015-07-09 16:42:21 UTC
(In reply to Marius Cornea from comment #6)
> Where should we set the dns server(s)? I don't see anything related in
> undercloud.conf but I might be missing something. Thanks

you set the dns servers by running a neutron subnet-update command prior to deploying the overcloud. this is included in the documentation.

Comment 11 errata-xmlrpc 2015-08-05 13:52:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.