Bug 122550 - OOo writer font color palette is missing 'Automatic' setting
Summary: OOo writer font color palette is missing 'Automatic' setting
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-05 17:56 UTC by Joe Smith
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-22 11:29:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Smith 2004-05-05 17:56:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
In OOo writer, the font color palette (the small floating window with
all the color swatches) normally has a label above the swatches with
the text 'Automatic'.  Clicking on a color swatch selects that color;
clicking on the 'Automatic' label means 'use the default color', i.e.,
there is no explicit color selected.

This has been the case in all OOo versions I have ever used; it is the
same in OOo 1.1.1 that I installed on my FC1 system.

In the OOo installed by an upgrade from FC1 to FC2_test3, the font
color palette window is missing the 'Automatic' label, so there is no
way to remove a manually applied color.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open OOo writer (new text document)
2. Click on the toolbar 'Font Color' icon
3. Color palette window opens
4. This window should have an 'Automatic' label; it does not, so there
is no way to select 'default color'.
    

Actual Results:  The palette window should have an 'Automatic' label

Expected Results:  The palette window does not have an 'Automatic'
label, so there is no way to select 'default color'.


Additional info:

I don't have the system in front of me; I can provide a screenshot at
a later time if needed.

Comment 1 Caolan McNamara 2004-10-08 09:28:48 UTC
In svx/source/dialogs/chardlg.cxx pFrame->GetBindings().QueryState(
SID_ATTR_AUTO_COLOR_INVALID, ...) is returning 48 when it should
return 1. 

I don't know yet what the root of this is :-), but that's the eventual
reason its missing from the dialogs.

Comment 2 Caolan McNamara 2004-10-08 14:47:57 UTC
Tracked it down to the gnome-vfs thing!, This is registered in
Configuration.xcu on a regexp of ".*" which captures all content
urls., It captures the "slot:" pseudo-urls which it shouldn't. OOo 1.1
searches for a slot:10933 for the automatic color before normally
giving up and explicitly adding it to the list of colours in the
various dialogs. 

Comment 3 Caolan McNamara 2004-10-08 15:57:42 UTC
perhaps a key of ^([^s]|s[^l]|sl[^o]|slo[^t]|slot[^:]).* will work...

Comment 4 Caolan McNamara 2004-10-11 08:36:26 UTC
upstream ooo-build has been patched to use the above regexp

Comment 5 Dan Williams 2004-10-19 19:22:27 UTC
caolan, note that in ooo-build now since its targetting 2.0, that
patch is gone.  Michael never did commit your patch either, which
means this might still be a problem in ooo-build and upstream.

Comment 6 Caolan McNamara 2004-10-22 11:29:42 UTC
nevertheless, its now ok in openoffice.org-1.1.2-10 for FC3


Note You need to log in before you can comment on or make changes to this bug.