Bug 1225519 - busybox FTBFS during stage1 bootstrap - storage size of ‘rlimit_fsize’ isn’t known - ‘RLIMIT_FSIZE’ undeclared
busybox FTBFS during stage1 bootstrap - storage size of ‘rlimit_fsize’ isn’t ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: busybox (Show other bugs)
21
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Denys Vlasenko
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks: fedora-bootstrap
  Show dependency treegraph
 
Reported: 2015-05-27 11:05 EDT by Jaromír Cápík
Modified: 2016-01-31 21:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-15 14:35:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
busybox.log (121.07 KB, text/plain)
2015-05-27 11:05 EDT, Jaromír Cápík
no flags Details

  None (edit)
Description Jaromír Cápík 2015-05-27 11:05:05 EDT
Description of problem:
Hello, we experience FTBFS during stage1 bootstrap and it seems the same issue has already been reported in scope of Bug 961542 and fixed with busybox-1.19-rlimit_fsize.patch.

The problem apparently lies in the following ifarch condition in the spec file. It doesn't include %{arm}
----
%ifarch ppc %{power64} s390 s390x aarch64
%patch3 -b .rlimit_fsize -p1
%endif
----

Build log tail
---------------
loginutils/passwd.c: In function ‘passwd_main’:
loginutils/passwd.c:104:16: error: storage size of ‘rlimit_fsize’ isn’t known
  struct rlimit rlimit_fsize;
                ^
loginutils/passwd.c:188:2: warning: implicit declaration of function ‘setrlimit’ [-Wimplicit-function-declaration]
  setrlimit(RLIMIT_FSIZE, &rlimit_fsize);
  ^
loginutils/passwd.c:188:12: error: ‘RLIMIT_FSIZE’ undeclared (first use in this function)
  setrlimit(RLIMIT_FSIZE, &rlimit_fsize);
            ^
loginutils/passwd.c:188:12: note: each undeclared identifier is reported only once for each function it appears in
loginutils/passwd.c:104:16: warning: unused variable ‘rlimit_fsize’ [-Wunused-variable]
  struct rlimit rlimit_fsize;
                ^
----------

Version-Release number of selected component (if applicable):
busybox-1.19.4-15.fc21

How reproducible:
always
Comment 1 Jaromír Cápík 2015-05-27 11:05:28 EDT
Created attachment 1030606 [details]
busybox.log
Comment 2 Jaromír Cápík 2015-05-28 19:57:42 EDT
The issue also appears on the i686 builder. That means it apparently affects all architectures. We cannot test x86_64 due to libgcc FTBFS.
Please add %{arm} and %{ix86} or consider removing the %ifarch condition completely.
Comment 3 Fedora Update System 2015-06-11 12:31:05 EDT
busybox-1.19.4-16.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/busybox-1.19.4-16.fc21
Comment 4 Fedora Update System 2015-06-13 02:39:21 EDT
Package busybox-1.19.4-16.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing busybox-1.19.4-16.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9910/busybox-1.19.4-16.fc21
then log in and leave karma (feedback).
Comment 5 Jaromír Cápík 2015-06-15 14:35:06 EDT
Seems fixed now. Thanks.

Note You need to log in before you can comment on or make changes to this bug.