Bug 1225552 - [Backup]: Unable to create a glusterfind session
Summary: [Backup]: Unable to create a glusterfind session
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterfind
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milind Changire
QA Contact: bugs@gluster.org
URL:
Whiteboard:
: 1226217 (view as bug list)
Depends On: 1221544
Blocks: qe_tracker_everglades glusterfs-3.7.1 1224109
TreeView+ depends on / blocked
 
Reported: 2015-05-27 16:28 UTC by Aravinda VK
Modified: 2015-06-02 06:22 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1221544
Environment:
Last Closed: 2015-06-02 06:22:58 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2015-05-27 16:28:00 UTC
+++ This bug was initially created as a clone of Bug #1221544 +++

Description of problem:
Passwordless ssh is not getting setup between the peers of a cluster

Version-Release number of selected component (if applicable):
glusterfs-3.7.0beta2-0.0.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have a 2 node cluster
2. Create a 2*2 distribute replicate volume 'ozone', and start it
3. Create a glusterfind session using 'glusterfind create'

Actual results:
It fails with the error - Failed to copy public key to /var/lib/glusterd/glusterfind/.keys

Expected results:
Glusterfind session should get successfully created

Additional info:

[root@dhcp43-140 ~]# glusterfind create sess1 ozone
Failed to copy public key to /var/lib/glusterd/glusterfind/.keys: [Errno 2] No such file or directory: '/var/lib/glusterd/glusterfind/.keys/sess1_ozone_secret.pem.pub'
[root@dhcp43-140 ~]# 
[root@dhcp43-140 ~]# cd /var/log/glusterfs/glusterfind/
[root@dhcp43-140 glusterfind]#
[root@dhcp43-140 glusterfind]# cat sess1/ozone/cli.log 
[2015-05-14 20:16:41,990] INFO [main - 266:ssh_setup] - Ssh key generated /var/lib/glusterd/glusterfind/sess1/ozone/sess1_ozone_secret.pem
[2015-05-14 20:16:41,993] ERROR [utils - 152:fail] - Failed to copy public key to /var/lib/glusterd/glusterfind/.keys: [Errno 2] No such file or directory: '/var/lib/glusterd/glusterfind/.keys/sess1_ozone_secret.pem.pub'
[2015-05-14 20:18:40,827] INFO [main - 266:ssh_setup] - Ssh key generated /var/lib/glusterd/glusterfind/sess1/ozone/sess1_ozone_secret.pem
[2015-05-14 20:18:40,829] ERROR [utils - 152:fail] - Failed to copy public key to /var/lib/glusterd/glusterfind/.keys: [Errno 2] No such file or directory: '/var/lib/glusterd/glusterfind/.keys/sess1_ozone_secret.pem.pub'

[root@dhcp43-140 glusterfind]# rpm -qa | grep gluster
glusterfs-api-3.7.0beta2-0.0.el6.x86_64
python-gluster-3.7.0beta2-0.0.el6.x86_64
glusterfs-libs-3.7.0beta2-0.0.el6.x86_64
glusterfs-3.7.0beta2-0.0.el6.x86_64
glusterfs-fuse-3.7.0beta2-0.0.el6.x86_64
glusterfs-server-3.7.0beta2-0.0.el6.x86_64
glusterfs-extra-xlators-3.7.0beta2-0.0.el6.x86_64
glusterfs-client-xlators-3.7.0beta2-0.0.el6.x86_64
glusterfs-cli-3.7.0beta2-0.0.el6.x86_64
[root@dhcp43-140 glusterfind]#

--- Additional comment from Sweta Anandpara on 2015-05-15 01:40:20 EDT ---

Sosreports copied to: http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/1221544/

--- Additional comment from Sweta Anandpara on 2015-05-18 02:36:06 EDT ---

On the latest build - glusterfs-3.7.0-2.el6rhs.x86_64, the same command fails with the below error:

[root@dhcp43-140 ~]# glusterfind create sess vol1
Failed to add ssh keys to authorized_keys file: gsync peer_add_secret_pub command not found.

[root@dhcp43-140 ~]#

--- Additional comment from Anand Avati on 2015-05-18 10:16:33 EDT ---

REVIEW: http://review.gluster.org/10807 (spec: Add missing file peer_add_secret_pub to the server RPM to support glusterfind independent of the geo-replication RPM) posted (#1) for review on master by Milind Changire (mchangir@redhat.com)

--- Additional comment from Anand Avati on 2015-05-19 05:43:56 EDT ---

REVIEW: http://review.gluster.org/10807 (spec: move file peer_add_secret_pub to server RPM) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)

--- Additional comment from Anand Avati on 2015-05-27 09:28:08 EDT ---

REVIEW: http://review.gluster.org/10807 (spec: move file peer_add_secret_pub to server RPM) posted (#3) for review on master by Milind Changire (mchangir@redhat.com)

Comment 1 Milind Changire 2015-05-29 09:23:23 UTC
*** Bug 1226217 has been marked as a duplicate of this bug. ***

Comment 2 Anand Avati 2015-05-31 06:49:59 UTC
REVIEW: http://review.gluster.org/11016 (spec: move file peer_add_secret_pub to server RPM) posted (#1) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)

Comment 3 Anand Avati 2015-05-31 09:07:28 UTC
REVIEW: http://review.gluster.org/11016 (spec: move file peer_add_secret_pub to server RPM) posted (#2) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)

Comment 4 Anand Avati 2015-05-31 13:36:28 UTC
REVIEW: http://review.gluster.org/11016 (spec: move file peer_add_secret_pub to server RPM) posted (#3) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)

Comment 5 Anand Avati 2015-06-01 03:53:31 UTC
REVIEW: http://review.gluster.org/11016 (spec: move file peer_add_secret_pub to server RPM) posted (#4) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)

Comment 6 Anand Avati 2015-06-01 09:16:25 UTC
REVIEW: http://review.gluster.org/11016 (spec: move file peer_add_secret_pub to server RPM) posted (#5) for review on release-3.7 by Aravinda VK (avishwan@redhat.com)

Comment 7 Anand Avati 2015-06-01 12:48:24 UTC
COMMIT: http://review.gluster.org/11016 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit cabb28a028b70172c45c72598e1ac43fbed08411
Author: Aravinda VK <avishwan@redhat.com>
Date:   Sun May 31 12:18:11 2015 +0530

    spec: move file peer_add_secret_pub to server RPM
    
    peer_add_secret_pub was developed as part of geo-replication
    feature. glusterfind has a dependency on the peer_add_secret_pub
    for distributing SSH secrets. The dependency was manifest while
    QA testing glusterfind. peer_add_secret_pub is now moved to the
    server RPM to support glusterfind without creating a dependency
    on the geo-replication RPM
    
    Change-Id: I1345e13fd6d218eb722cd72ca1b9dd04adf4d316
    BUG: 1225552
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-On: http://review.gluster.org/10807
    Reviewed-on: http://review.gluster.org/11016
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>


Note You need to log in before you can comment on or make changes to this bug.