Bug 1225562 - [abrt] plank: wnck_screen_construct(): plank killed by SIGSEGV
Summary: [abrt] plank: wnck_screen_construct(): plank killed by SIGSEGV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plank
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Wesley Hearn
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:91fda9b12ac4d95e3afafce6b16...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-27 16:40 UTC by Aleksandr
Modified: 2015-12-01 19:50 UTC (History)
1 user (show)

Fixed In Version: plank-0.10.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-01 19:50:49 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (33.03 KB, text/plain)
2015-05-27 16:40 UTC, Aleksandr
no flags Details
File: cgroup (190 bytes, text/plain)
2015-05-27 16:40 UTC, Aleksandr
no flags Details
File: core_backtrace (15.79 KB, text/plain)
2015-05-27 16:40 UTC, Aleksandr
no flags Details
File: dso_list (9.10 KB, text/plain)
2015-05-27 16:40 UTC, Aleksandr
no flags Details
File: environ (989 bytes, text/plain)
2015-05-27 16:40 UTC, Aleksandr
no flags Details
File: limits (1.29 KB, text/plain)
2015-05-27 16:40 UTC, Aleksandr
no flags Details
File: maps (41.97 KB, text/plain)
2015-05-27 16:40 UTC, Aleksandr
no flags Details
File: mountinfo (3.48 KB, text/plain)
2015-05-27 16:40 UTC, Aleksandr
no flags Details
File: namespaces (85 bytes, text/plain)
2015-05-27 16:40 UTC, Aleksandr
no flags Details
File: open_fds (1.22 KB, text/plain)
2015-05-27 16:40 UTC, Aleksandr
no flags Details
File: proc_pid_status (953 bytes, text/plain)
2015-05-27 16:40 UTC, Aleksandr
no flags Details
File: var_log_messages (622 bytes, text/plain)
2015-05-27 16:40 UTC, Aleksandr
no flags Details

Description Aleksandr 2015-05-27 16:40:23 UTC
Version-Release number of selected component:
plank-0.8.1-1.fc22

Additional info:
reporter:       libreport-2.5.1
backtrace_rating: 4
cmdline:        plank
crash_function: wnck_screen_construct
executable:     /usr/bin/plank
global_pid:     2288
kernel:         4.0.4-301.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 wnck_screen_construct at screen.c:538
 #1 wnck_screen_get at screen.c:601
 #2 wnck_screen_get_default at screen.c:638
 #3 plank_items_default_application_dock_item_provider_constructor at Items/DefaultApplicationDockItemProvider.c:1160
 #4 g_object_new_with_custom_constructor at gobject.c:1692
 #5 g_object_new_internal at gobject.c:1772
 #6 g_object_new_valist at gobject.c:2033
 #8 plank_dock_controller_get_default_provider at DockController.c:597
 #9 plank_dock_controller_add_default_provider at DockController.c:547
 #10 plank_dock_controller_initialize at DockController.c:518

Comment 1 Aleksandr 2015-05-27 16:40:27 UTC
Created attachment 1030696 [details]
File: backtrace

Comment 2 Aleksandr 2015-05-27 16:40:29 UTC
Created attachment 1030697 [details]
File: cgroup

Comment 3 Aleksandr 2015-05-27 16:40:30 UTC
Created attachment 1030698 [details]
File: core_backtrace

Comment 4 Aleksandr 2015-05-27 16:40:32 UTC
Created attachment 1030699 [details]
File: dso_list

Comment 5 Aleksandr 2015-05-27 16:40:33 UTC
Created attachment 1030700 [details]
File: environ

Comment 6 Aleksandr 2015-05-27 16:40:34 UTC
Created attachment 1030701 [details]
File: limits

Comment 7 Aleksandr 2015-05-27 16:40:37 UTC
Created attachment 1030702 [details]
File: maps

Comment 8 Aleksandr 2015-05-27 16:40:38 UTC
Created attachment 1030703 [details]
File: mountinfo

Comment 9 Aleksandr 2015-05-27 16:40:39 UTC
Created attachment 1030704 [details]
File: namespaces

Comment 10 Aleksandr 2015-05-27 16:40:41 UTC
Created attachment 1030705 [details]
File: open_fds

Comment 11 Aleksandr 2015-05-27 16:40:42 UTC
Created attachment 1030706 [details]
File: proc_pid_status

Comment 12 Aleksandr 2015-05-27 16:40:43 UTC
Created attachment 1030707 [details]
File: var_log_messages

Comment 13 Wesley Hearn 2015-05-27 16:46:49 UTC
0.9.1 is in testing and is about to get moved to stable. Can you try reproducing with it?

Comment 14 Wesley Hearn 2015-06-03 21:16:53 UTC
So this is because plank does not support wayland. Working with upstream to make this apparent instead of just crashing.

Comment 15 Fedora Update System 2015-06-03 22:33:59 UTC
plank-0.9.1-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/plank-0.9.1-2.fc21

Comment 16 Fedora Update System 2015-06-03 22:34:05 UTC
plank-0.9.1-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/plank-0.9.1-2.fc22

Comment 17 Fedora Update System 2015-06-05 23:39:25 UTC
Package plank-0.9.1-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing plank-0.9.1-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9430/plank-0.9.1-2.fc22
then log in and leave karma (feedback).

Comment 18 Fedora Update System 2015-09-12 23:55:22 UTC
plank-0.10.0-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15712

Comment 19 Fedora Update System 2015-09-14 02:49:35 UTC
plank-0.10.0-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update plank'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15712

Comment 20 Fedora Update System 2015-10-28 19:25:13 UTC
plank-0.10.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ab64991227

Comment 21 Fedora Update System 2015-11-02 00:27:04 UTC
plank-0.10.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update plank'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ab64991227

Comment 22 Fedora Update System 2015-12-01 19:50:47 UTC
plank-0.10.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.