Bug 122563 - vera fonts duplicated in xorg-x11-truetype-fonts and in bitstream-vera-fonts
vera fonts duplicated in xorg-x11-truetype-fonts and in bitstream-vera-fonts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-05-05 15:38 EDT by petrosyan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 14:56:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2004-05-05 15:38:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040504

Description of problem:
I am not sure wether I should file this against bitstream-vera-fonts
or xorg-x11-truetype-fonts but all of the Vera TTF fonts from
bitstream-vera-fonts are duplicated in xorg-x11-truetype-fonts package
which looks like a waste of space to me.

Version-Release number of selected component (if applicable):
bitstream-vera-fonts-1.10-3

How reproducible:
Always

Steps to Reproduce:
1. rpm -ql bitstream-vera-fonts
2. rpm -ql xorg-x11-truetype-fonts
3. diff /usr/share/fonts/bitstream-vera/Vera.ttf
/usr/X11R6/lib/X11/fonts/TTF/Vera.ttf

Actual Results:  the fonts are identical
Comment 1 Owen Taylor 2004-09-02 14:15:41 EDT
SHould be removed from of the X packaging, in my opinion. Trying
to merge the separate package back into the X11 package doesn't make
sense to me.
Comment 2 Mike A. Harris 2004-09-02 14:56:24 EDT
This problem was fixed yesterday internally and should be fixed
externally within a few days or so.

The real problem, is that the xorg-x11 build used the following
glob for including truetype fonts that get generated during build:

%{_x11fontdir}/TTF/*.ttf

That all inclusive glob means that no .ttf files would get left
behind, however it also means that we're never made aware of new
ttf fonts getting added to the X.Org source tree, since we just
always include whatever is built.  I noticed the Vera TTF fonts
via visual inspection while creating the new fonts-xorg noarch
fonts package, and fixed this problem in both the fonts-xorg
and xorg-x11 packaging, so that we no longer include the Vera
fonts there, since they're provided by the bitstream-vera-fonts
package.

fonts-xorg-6.7.99.903-3 and xorg-x11-6.7.99.903-3 packages should
resolve this once they're in rawhide.

Thanks for the report.

Setting status to "RAWHIDE".

Note You need to log in before you can comment on or make changes to this bug.