Bug 122565 - rpmdb: fatal region error detected; run recovery
rpmdb: fatal region error detected; run recovery
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
s390x Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-05 15:55 EDT by Suzanne Hillman
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-06 06:44:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2004-05-05 15:55:51 EDT
Description of problem:
Trying to do anything with the rpm database on kryten.z900.redhat.com
results in:

rpmdb: fatal region error detected; run recovery
error: db4 error(-30982) from dbenv->open: DB_RUNRECOVERY: Fatal
error, run database recovery
error: cannot open Packages index

This is not fixable using rpmdb_dump Packages-ORIG | rpmdb_load
Packages, and rpm --rebuilddb results in the same error as above. We
shall try rebooting next, as this machine really is needed for errata
testing.


Version-Release number of selected component (if applicable):
RPM version 4.2.1

How reproducible:
Always.

Steps to Reproduce:
1. Try to use rpm, for example, rpm -q rpm
  
Actual results:
Error as listed above.

Expected results:
No error. Should work.

Additional info:
Not sure what might have caused this, as it was in this state when I
got to it.
Comment 1 Suzanne Hillman 2004-05-05 16:08:25 EDT
FYI - rebooting seems to have fixed it, and since I have no idea how
to reproduce, this probably ought to be closed.

Note You need to log in before you can comment on or make changes to this bug.