Bug 122571 - Provioning fails when using MS IIS 6.0 as the HTTP server
Provioning fails when using MS IIS 6.0 as the HTTP server
Status: CLOSED DUPLICATE of bug 108652
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda (Show other bugs)
2.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-05 17:08 EDT by David J. Silbermann
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David J. Silbermann 2004-05-05 17:08:06 EDT
Description of problem:
While trying to provision AS2.1 onto a bare metal machine over HTTP, 
the HTTP GET fails with "HTTP/1.1 400 Bad Request" error.  I believe 
that this is because the HTTP request is not compliant with RFC 
2616.  In particular, the RFC calls for the HTTP request to be 
terminated by a CRLF (hex: 0D 0A), the actaul request seems to be 
terminated with 09 0A 

The problem occurs with Microsoft Internet Information Server (IIS) 
6.0.  IIS 5.0 and Apache for Windows appear to be more tolerant, and 
deal with the malformed request correctly.   

Version-Release number of selected component (if applicable):
AS2.1

How reproducible:
Provision AS2.1 onto a machine over HTTP using MS IIS6.0 as an HTTP 
server

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2004-05-12 16:43:31 EDT
This is fixed in newer update releases of RHEL 2.1

*** This bug has been marked as a duplicate of 108652 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.