Bug 1225713 - Can not add XFCE4 Places plugin to panel
Summary: Can not add XFCE4 Places plugin to panel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-places-plugin
Version: 22
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-28 04:49 UTC by Shivaji Sathe
Modified: 2015-07-02 17:08 UTC (History)
6 users (show)

Fixed In Version: xfce4-places-plugin-1.7.0-3.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-02 17:08:03 UTC


Attachments (Terms of Use)
Proposed patch which worked locally for me (1.33 KB, patch)
2015-06-21 04:30 UTC, Shivaji Sathe
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Xfce 11939 None None None Never

Description Shivaji Sathe 2015-05-28 04:49:38 UTC
Description of problem:
Can not add XFCE4 Places plugin to panel

Version-Release number of selected component (if applicable):
1.6.0-4.fc22

How reproducible:
Try to add the Places item to XFCE panel

Steps to Reproduce:
1.Upgrade from F21 XFCE spin to F22 using FedUp
2.Existing Places plugin did not work and crashed.
3.Trying to add again failed

Actual results:
Places plugin did not show up.

Expected results:
XFCE panel gives error saying Plugin "Places" unexpectedly left the panel, do you want to restart it?

Additional info:
I tried running panel on terminal it gives:

(process:28473): xfce4-panel-wrapper-CRITICAL **: Wrapper places-12: Failed to open plugin module "/usr/lib64/xfce4/panel/plugins/libplaces.so": /usr/lib64/xfce4/panel/plugins/libplaces.so: undefined symbol: places_bookmark_destroy.
xfce4-panel-Message: Plugin places-12 has been automatically restarted after crash.

(process:28474): GLib-WARNING **: (gerror.c:383):g_error_new_valist: runtime check failed: (domain != 0)

(process:28474): xfce4-panel-wrapper-CRITICAL **: Wrapper places-12: Failed to open plugin module "/usr/lib64/xfce4/panel/plugins/libplaces.so": /usr/lib64/xfce4/panel/plugins/libplaces.so: undefined symbol: places_bookmark_destroy.

Comment 1 Kevin Fenzi 2015-05-28 12:23:41 UTC
Filed upstream: https://bugzilla.xfce.org/show_bug.cgi?id=11939

I can't see why you marked this bug private... was there some reason?

Comment 2 Shivaji Sathe 2015-05-28 16:39:01 UTC
Thanks for filing upstream, I hope it's valid issue and helps :)

I have used Fedora for fairly long time. However, apart from couple of ABRT reports, this is first time I have manually filed Fedora issue. There is no other reason than keeping the email private as much as possible. I thought issue would be still searchable who have bugzilla account.

It's not letting me unmark the private status now. I will keep in mind next time.

Comment 3 Konstantin Svist 2015-06-02 16:32:07 UTC
hitting the same bug after fedup

Comment 4 hannes 2015-06-15 08:11:44 UTC
I think, there's an easy fix in the upstream bugzilla. Basically it's because of gcc5.

Comment 5 Kevin Fenzi 2015-06-15 13:36:09 UTC
I played around with it some last week and was unable to get that fix to work...

Comment 6 Shivaji Sathe 2015-06-21 04:30:37 UTC
Created attachment 1041339 [details]
Proposed patch which worked locally for me

I got a chance to work with the sources myself. From what I understood I replaced "inline" with "extern inline" in model.h. I think it shouldn't break gnu89 compatibility either. I built the package locally and worked for me.

Is it possible to review and integrate the patch at least for Fedora?

Comment 7 hannes 2015-06-21 07:50:33 UTC
I can confirm the fix, please find a scratch build here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=10172853

Comment 8 Shivaji Sathe 2015-06-21 17:04:23 UTC
I installed koji package and have started using Places plugin now. So does that mean this will be part of fedora update eventually?

Comment 9 Fedora Update System 2015-06-21 18:43:29 UTC
xfce4-places-plugin-1.7.0-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/xfce4-places-plugin-1.7.0-3.fc22

Comment 10 Kevin Fenzi 2015-06-21 18:45:15 UTC
Thanks much for the patch!

Would you like to attach it to the upstream bug as well?

Comment 11 Shivaji Sathe 2015-06-22 03:00:20 UTC
Sure, you may attach the patch there for XFCE devs to consider.

Comment 12 Kevin Fenzi 2015-06-22 14:37:03 UTC
Sure, done. Thanks again.

Comment 13 Shivaji Sathe 2015-06-23 03:13:06 UTC
Thanks. Glad I could help.

Comment 14 Fedora Update System 2015-06-23 09:09:25 UTC
Package xfce4-places-plugin-1.7.0-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-places-plugin-1.7.0-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10530/xfce4-places-plugin-1.7.0-3.fc22
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2015-07-02 17:08:03 UTC
xfce4-places-plugin-1.7.0-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.