Bug 1225922 - Sharding - Skip update of block count and size for directories in readdirp callback
Summary: Sharding - Skip update of block count and size for directories in readdirp ca...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: sharding
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Krutika Dhananjay
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1221104
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-28 13:06 UTC by Krutika Dhananjay
Modified: 2015-06-02 08:24 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1221104
Environment:
Last Closed: 2015-06-02 08:03:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2015-05-28 13:06:00 UTC
+++ This bug was initially created as a clone of Bug #1221104 +++

Description of problem:
Sharding translator, in readdirp callback, need not update the block count and file size in entry->d_stat if the inode is a directory. This BZ is to fix the bug.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-05-13 09:54:28 EDT ---

REVIEW: http://review.gluster.org/10772 (features/shard: Skip block count and size update for directories) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Anand Avati on 2015-05-17 10:34:34 EDT ---

REVIEW: http://review.gluster.org/10772 (features/shard: Skip block count and size update for directories) posted (#2) for review on master by Vijay Bellur (vbellur@redhat.com)

--- Additional comment from Anand Avati on 2015-05-18 13:06:08 EDT ---

REVIEW: http://review.gluster.org/10772 (features/shard: Skip block count and size update for directories) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

--- Additional comment from Anand Avati on 2015-05-28 01:43:44 EDT ---

COMMIT: http://review.gluster.org/10772 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 58a687a8e0967393428bc5f93f0d32bbc3792f88
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed May 13 11:44:49 2015 +0200

    features/shard: Skip block count and size update for directories
    
    Change-Id: Iaa7022c95a8d9c9c471db025ec644e0bcc4eeb29
    BUG: 1221104
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/10772
    Tested-by: NetBSD Build System
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 1 Anand Avati 2015-05-28 13:10:50 UTC
REVIEW: http://review.gluster.org/10972 (features/shard: Skip block count and size update for directories) posted (#1) for review on release-3.7 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Anand Avati 2015-05-29 02:24:31 UTC
COMMIT: http://review.gluster.org/10972 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit bef714fa854536bf4a40d9d83a11945cb21248cb
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed May 13 11:44:49 2015 +0200

    features/shard: Skip block count and size update for directories
    
            Backport of: http://review.gluster.org/10772
    
    Change-Id: I3594641ef0bf6a17e1ceab3c9ad87ef18b981d2e
    BUG: 1225922
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/10972
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 3 Niels de Vos 2015-06-02 08:03:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.1, please reopen this bug report.

glusterfs-3.7.1 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/1
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.