Bug 1225923 - Content > Red Hat Subscriptions landing page/endpoint is not uniform
Summary: Content > Red Hat Subscriptions landing page/endpoint is not uniform
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-28 13:06 UTC by Corey Welton
Modified: 2019-09-25 20:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:52:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 10721 None None None 2016-04-22 15:57:41 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Corey Welton 2015-05-28 13:06:53 UTC
Description of problem:
Sometimes when user navigates to Content > Red Hat Subscriptions, they are taken to 

/subscriptions

... but other times when navigating, via the UI, to the same location, they are taken/redirected to 

/subscriptions/manifest/import


Version-Release number of selected component (if applicable):
Snap6

How reproducible:
I have one reproducible case but I am not sure it is the best

Steps to Reproduce:
1.  Install satellite.  Navigate to Content > Lifecycle Environments (or nearly anywhere else in the UI) and then to Content > Red Hat Subscriptions 
2.  Observe user is taken to /subscriptions/manifest/import endpoint
3.  From within the Subscriptions page itself (and perhaps other pages?) nav to Content > Red Hat Subscriptions
4.  Observe results.

Actual results:

Depending where you are or in certain circumstances (heuristic not completely known though as noted we have a repro case here), "Content > Red Hat Subscriptions" takes user to one of two different endpoints.  

Expected results:

Content > Red Hat Subscriptions always take user to same page/endpoint.


Additional info:
Such behavior is confusing and will lead to support calls with people wondering what is going on.  I am willing to remove blocker if:

(a) the heuristic is fully determined and 
(b) found to be limited to navigating to "Content > Red Hat Subscriptions" from within the Manage/Import Manifests page itself, and
(b) This is doc'd.

Comment 3 Walden Raines 2015-06-05 19:22:16 UTC
Created redmine issue http://projects.theforeman.org/issues/10721 from this bug

Comment 4 Walden Raines 2015-06-18 18:26:25 UTC
I personally don't think this meets the qualifications for high severity and for going into a point release.

Comment 5 Bryan Kearney 2015-08-14 17:01:44 UTC
Upstream bug assigned to ehelms@redhat.com

Comment 6 Bryan Kearney 2015-08-14 17:01:45 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/10721 has been closed
-------------
Eric Helms
Applied in changeset commit:katello|2c38e0689ff3918cc052e86887a3aaecaf9ee275.

Comment 7 Tazim Kolhar 2015-10-15 13:46:03 UTC
*** This bug is verified in upstream.  This fix should eventually land in future downstream builds ***


VERIFIED:
# rpm -qa | grep foreman
nec-em17.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
foreman-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
nec-em17.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201510071112git33fd59b.el7.noarch
foreman-debug-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
foreman-release-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
foreman-postgresql-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
foreman-vmware-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-libvirt-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
foreman-ovirt-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
nec-em17.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
tfm-rubygem-foreman_discovery-4.1.0-1.fm1_10.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
foreman-proxy-1.11.0-0.develop.201510120849git5f36f2e.el7.noarch
foreman-compute-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch
foreman-gce-1.11.0-0.develop.201510121538gitb6b977a.el7.noarch

Comment 11 errata-xmlrpc 2016-07-27 08:52:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.